Alfa Romeo Bulletin Board & Forums - Reply to Topic
Thread: tranny for 1600 bellhousing? Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-23-2012 06:48 PM
hotlegs32 Just sealed. I have never welded one in and have had no problems.
But without a reverse switch as they were for early Spiders.
05-23-2012 05:25 PM
lotuseleven Karen, does the cover plate need to be welded or sealed in the opening?
05-23-2012 05:15 PM
hotlegs32 And a plate to cover the shift rod opening. With a bracket for the reverse switch, if you want a reverse light. Otherwise there will be an oil leak because the later short shift rods do not have "0" rings to seal them.
05-23-2012 04:22 PM
Alfar7
115 series in 101 bell housing

Only needs correct oil seal with smaller center to fit. I keep them in stock.
05-23-2012 03:16 PM
lotuseleven This is what I was expecting to see, and have seen threads about adapting this transmission for the early bellhousing.
05-23-2012 03:13 PM
lotuseleven
tranny for 1600 bellhousing?

Could someone please identify this transmission, and tell me if it can be mounted to a 1600 bellhousing? I'm pretty sure that it was sourced by the PO to install in a 73 spider, but it doesn't look like I expected. want to use it with a cable clutch if it will work in the 1600 bellhousing.
thanks for all help,
Stan

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome