Alfa Romeo 75 (Milano) Speedometer Problem - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-03-2019, 09:21 AM Thread Starter
Registered User
 
Join Date: Apr 2019
Location: Tebay, Cumbria
Posts: 3
Alfa Romeo 75 (Milano) Speedometer Problem

Hi all,

I spend a lot of time on the Alfa Owner UK website, and have come up short with an issue I am having. I have read similar threads on here this week to help guide me through but I am coming up short and I am not able to match the exact symptoms. If anybody could give me a bit of guidance, and possible solutions perhaps, it would be most appreciated.

Issue
  • Speedometer needle Jumps clockwise to the highest speed/point on the speedometer dial
  • It jumps when you turn the key to position one
  • It stays in this position as the car runs after starting
  • There is a distinctive motor-like buzzing noise from the speedometer
  • No amount of hitting the top of the dash helps (I am quite gentle with the 75)

Thus far, I have had the cluster off the dash to check connections and I have cleaned each up. Nothing seemed untoward.

I have also had a look at the Jaeger Box that sits under the rear seats (mine is there). I disconnected connectors independently and this did not impact the speedometer issue above.

The car has started normally as recently as a few weeks ago. After that start, I had to re-torque the head in-line with the Workshop Manual post Head Gasket job, refit an alternator, and I have also done some front suspension work. This speedo issue arose after this was complete.

Many thanks in advance.
Kane Antony Ray is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-03-2019, 10:22 AM
Senior Member
Platinum Subscriber
 
alfaparticle's Avatar
 
Join Date: Oct 2004
Location: Columbia SC
Posts: 12,980
It looks like the speedometer itself has gone bad. I would buy a used one and swap it out.

Ed Prytherch
79 Spider
76 Suzuki GT500
2011 Jaguar XKR

A little government and a little luck are necessary in life, but only a fool trusts either of them. - P.J. O'Rourke
alfaparticle is online now  
post #3 of 6 (permalink) Old 05-03-2019, 10:27 AM
But Mad North-Northwest
Platinum Subscriber
 
Gubi's Avatar
 
Join Date: Sep 2003
Location: SF Bay Area, CA
Posts: 9,822
I had this exact problem, it was a bad chip of some sort in the speedometer itself. A local shop was able to repair it.

Tom

1963 Giulia Spider (1750 engine)
1974 GTV
1991 Spider
Former: 1987 Milano Gold
Gubi is online now  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 05-03-2019, 02:17 PM Thread Starter
Registered User
 
Join Date: Apr 2019
Location: Tebay, Cumbria
Posts: 3
Thank you for the respective replies. At least it looks like it is something I have not done incorrectly.

Sent from my TA-1020 using Tapatalk
Kane Antony Ray is offline  
post #5 of 6 (permalink) Old 08-18-2019, 06:42 AM
Registered User
 
tool75's Avatar
 
Join Date: Apr 2019
Posts: 10
What to look for if speedometer needle is not stable? It works, its accurate but it is hanging left and right, mostly in high speeds and accelerations.
Is the sender or the speedometer cluster or something in gearbox where the white sender reads? (I have a slight rattle sound on idle from gearbox).
Also I have to take of the needle to repair km counter. Maybe I have ruined something when I was fiddling with that? Don t know if the problem was before because I never drive it before on high speeds when problem is visible at most.

EDIT: problem solved _ dont know what the cause was but I have done 3 things. 1. Clean gearbox sender from oil deposits, 2. sort and clean sender conector, 3. repair km to 0 counter.

Last edited by tool75; 08-30-2019 at 04:51 AM. Reason: possible solutions of the problem
tool75 is offline  
post #6 of 6 (permalink) Old 08-18-2019, 11:32 AM
Senior Member
Platinum Subscriber
 
alfaparticle's Avatar
 
Join Date: Oct 2004
Location: Columbia SC
Posts: 12,980
Pointer touching something? static electricity?

Ed Prytherch
79 Spider
76 Suzuki GT500
2011 Jaguar XKR

A little government and a little luck are necessary in life, but only a fool trusts either of them. - P.J. O'Rourke
alfaparticle is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Supplier List Roadtrip Guests, New Members & Introductions - Please Read 136 06-28-2019 01:22 PM
FIRST 100 Giulietta Sprint Veloce Marco750B56 Giulietta & Giulia (1954-65) 25 05-19-2019 10:40 PM
Alfa Romeo - Guida dei Servici Assistenziali tubut Alfa Romeo History 13 05-26-2017 07:55 AM
Alfa Romeo 8c Competizione.....'Authentic Emotions' DJTaurus Alfa Romeo 8C Competizione - Spider 735 03-31-2010 10:20 AM
2009 Alfa Romeo Deportivos de El Salvador Reglamento italcarguy El Salvador 0 10-01-2008 10:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome