no power to a/c - 1984 Spider - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-29-2018, 11:23 AM Thread Starter
Registered User
 
Join Date: Oct 2017
Location: Florida
Posts: 2
no power to a/c - 1984 Spider

I need help tracing the power supply to the a/c switch. The wiring diagram lists a 20 amp inline fuse with power coming from the ignition switch, brown wire. The only inline fuse I can find is above the fusebox (blade type) using red wires with white stripe that comes from the back of the fusebox. Thanks in advance for any help provided.
tavbfl is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-29-2018, 11:48 AM
Trained (ex)Professional

1953-2018 RIP

Platinum SubscriberAdministrator
 
papajam's Avatar
 
Join Date: Feb 2003
Location: New Jersey USA
Posts: 16,232
Try by the electrical junction block in the engine bay. It's on the left inner fender by the brake master cylinder. There's a bunch of red wires and 2 green wires in it. Alfa used this location to attach a 20A in-line A/C fuse.
There is a 2nd A/C fuse that I thought was in the vicinity of the fusebox.

Jim

Series 2 USA 1750 GTV (in Series 1 European clothing)
papajam is offline  
Reply

Tags
a/c, fuse

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome