New Member - need assistance - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-26-2019, 06:52 AM Thread Starter
Registered User
 
Join Date: Apr 2019
Posts: 2
New Member - need assistance

I've just acquired a '93 Spider Veloce. Runs great but the speedometer does not work. Sending unit has been replaced. Pretty sure the problem in is the speedometer itself. Does anyone know how this instrument is removed? I have not been able to find anything on the internet for this model Alfa.

Thanks!
hdplunkett is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-26-2019, 09:58 AM
BB Janitor
Platinum SubscriberAdministratorSuper Moderator
 
ghnl's Avatar
 
Join Date: Oct 2005
Location: Mebane, NC
Posts: 16,271
Garage
Try these threads: https://www.alfabb.com/bb/forums/spi...4-spiders.html

and: https://www.alfabb.com/bb/forums/spi...ch-speedo.html

- - Eric
don't read this
~ 1984 Spider Veloce ~
- -~ 1981 GTV-6 ~
Mebane, North Carolina


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
ghnl is offline  
post #3 of 3 (permalink) Old 04-27-2019, 02:12 PM Thread Starter
Registered User
 
Join Date: Apr 2019
Posts: 2
Thanks - very helpful!
hdplunkett is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alfsito Steve's daily blog Alfisto Steve 164 & 168 (1991-1995) 84 12-03-2017 05:35 PM
Body to trasmission cross member HUD Giulietta & Giulia (1954-65) 6 06-01-2016 06:35 PM
New ABB member needing assistance Rrepasi Alfa Romeo Topics Not Covered Elsewhere 4 03-17-2014 07:47 PM
Front X member tomcotez GT (1963-1977) 0 01-14-2014 04:34 AM
82 Alfa GTV6 Drive Shaft Cross Member cchan Alfetta & GTV6 (1972-1986) 1 01-22-2007 09:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome