Alfa Romeo Bulletin Board & Forums

Alfa Romeo Bulletin Board & Forums (https://www.alfabb.com/bb/forums/)
-   GT (1963-1977) (https://www.alfabb.com/bb/forums/gt-1963-1977/)
-   -   New owner 1974 GTV has no idea what he got himself into (https://www.alfabb.com/bb/forums/gt-1963-1977/643178-new-owner-1974-gtv-has-no-idea-what-he-got-himself-into.html)

evermore 03-08-2018 08:55 AM

New owner 1974 GTV has no idea what he got himself into
 
3 Attachment(s)
Good morning Alfisti,

I just received my 1974 Alfa Romeo GTV yesterday. It was listed at BHCC and is in running condition but unrestored. My main aim is to get it fixed up so that I can drive it on a daily basis.

- While I purchased the car in Los Angeles, I cannot be sure that is where BHCC got it from. It is not a US-spec car as it has the Weber carbs and the speedometer is in km/h. I have the vehicle number (AR2443083) and the engine number (1Z (?) 005512*28920) so figuring out the original country of sale would be interesting.. do I just contact Marco Fazio?


- The engine starts up easily and runs fine.. well except that the cover on the airbox had come off so that surely screws up the air/fuel mixture.
- I can reverse and all 5 gears engage. I am having some difficulty engaging second gear smoothly (without some gear grinding noise). Could just be me but I will monitor.
- Braking was.. well far worse than my 4Runner.
- Rear right coil spring is broken. The two pieces of coil sit on top of each other so this clearly needs fixing.
- As for the rest of the underside... let's just say here there be dragons. Will update when I can .

Plan of action is to take take detailed photos of well pretty much anything this weekend, then take it to Rich at Continental Motors to get a basic service and determine if there is any need of work on that end.

Given that one of the coil springs has failed completely, replacing them and the dampeners all around is a logical first project. I might do brakes and bushings at the same time.

I will update with more photos this weekend.

Cheers!

Michael
Willow Glen, CA

horsewidower 03-08-2018 09:33 AM

Welcome, always nice to see another one getting ready for road service.

Bob

Alfajay 03-08-2018 09:34 AM

Quote:

Originally Posted by evermore (Post 8101322)
The engine starts up easily and runs fine.. well except that the cover on the airbox had come off so that surely screws up the air/fuel mixture.

It probably wouldn't screw it up that much - but it would admit unfiltered air into the carbs, which isn't good.

Quote:

I can reverse and all 5 gears engage. I am having some difficulty engaging second gear smoothly (without some gear grinding noise).
Redline, or other brands of synthetic oil may improve this. Search the BB for recommendations.

Quote:

- Braking was.. well far worse than my 4Runner.
Your mechanic may find a stuck caliper or non-functioning booster. Do the brakes pull to one side?

Quote:

- Rear right coil spring is broken. The two pieces of coil sit on top of each other so this clearly needs fixing.
That's odd - does the RR corner sit low? Are you sure it isn't just a piece of tubing around the lower 2-3 coils on the spring? If the spring is truly broken, the car wouldn't be driveable.

PSk 03-08-2018 09:40 AM

Welcome and you have lots of enjoyment ahead of you.

I don't want to be an alarmist, but something very strange is going on with your front panel. The side line and top of the guard line are supposed to meet and then run along the top of the front, but your side line is too low ...

Found a photo that shows how it supposed to be: http://www.alfabb.com/bb/forums/atta...1&d=1145976485
Pete

evermore 03-08-2018 09:50 AM

1 Attachment(s)
Quote:

Originally Posted by Alfajay (Post 8101386)
Your mechanic may find a stuck caliper or non-functioning booster. Do the brakes pull to one side?

That's odd - does the RR corner sit low? Are you sure it isn't just a piece of tubing around the lower 2-3 coils on the spring? If the spring is truly broken, the car wouldn't be driveable.

Regarding the brakes, I did not notice some huge pull to one side or another. Steering was a bit vague but I figure that is because of ancient bushings.

As for the coil, attached is a picture of the coil I took yesterday, will try to get more detailed shots..

evermore 03-08-2018 09:59 AM

Quote:

Originally Posted by PSk (Post 8101410)
Welcome and you have lots of enjoyment ahead of you.

I don't want to be an alarmist, but something very strange is going on with your front panel. The side line and top of the guard line are supposed to meet and then run along the top of the front, but your side line is too low ...

Found a photo that shows how it supposed to be:
Pete

Hi Pete,

If I understand you correctly, you are saying the front bumper is hanging too low and I can see it is at least a cm down. I will check if this is because the mounts are bent or some other reason.

Antonio105 03-08-2018 11:16 AM

I think you are missing the carriage bolts that go from the over riders to the inside of the body - you can fix that easily. Nice car overall..I would assume it needs some good TLC to fix previous owners negligence

PSk 03-08-2018 12:33 PM

649 Attachment(s)
Quote:

Originally Posted by evermore (Post 8101458)
Quote:

Originally Posted by PSk (Post 8101410)
Welcome and you have lots of enjoyment ahead of you.

I don't want to be an alarmist, but something very strange is going on with your front panel. The side line and top of the guard line are supposed to meet and then run along the top of the front, but your side line is too low ...

Found a photo that shows how it supposed to be:
Pete

Hi Pete,

If I understand you correctly, you are saying the front bumper is hanging too low and I can see it is at least a cm down. I will check if this is because the mounts are bent or some other reason.

No I was not talking about the front bumper but the swage/body line/crease that runs from the back of the car through the doors and front guard panel.

It should meet the top of the guard line and the run along the top most line of the nose panel. Yours does not ...
Pete
[edit:]But yes your bumper does point down too ... easy fix I assume :)[/edit]

UndecidedRacer 03-08-2018 01:07 PM

Welcome to the neighborhood and the family!
 
Hi Michael - congrats and welcome to the family. I joined in May of last year with a BAT auction win. I am working on taking it from stock to more of a canyon carver. As i am in your area (Menlo Park), happy to talk further about what i have learned in terms of refinishing things myself vs having to go outside to a shop for support. I am nearing the end of this go-fast upgrade which has included everything from a motor rebuild/upgrade, gearbox rebuild with alcoholics racing parts, and even some interior work including sparco seats and harness bar and because i am tall i have also done a lot of work with the steering column/removing the center console, and having some custom fab work done.

Reach out anytime.

Cheers,
Phil

Yousuf22 03-08-2018 02:46 PM

Nice GTV! Im sure you'll really enjoy it when its sorted.

Regarding the gearbox, i had the typical 2nd gear crunch, and rev matching aside i found using an additive called 'Slick 50' helped a fair bit. I took the car for a 20 mile run and the crunch became less and less prominent, especially when warmed up. It's not completely eradicated, but it is improved and when coupled with rev matching you can just forget about it. Of course, its not really recommended to use additives like this but since you'll probably need a rebuild sooner or later anyway you dont have much to lose.

Play in the steering is pretty common, the six tie rod ends can wear out and contribute. A worn out steering box can also be a culprit, a temporary solution is to experiment with removing shims on the Burman box or the adjustment screw on the ZF box, depending on which your car has installed. Low tyre pressures can also play a part, as well as alignment.

Hope you get on well with it!

Yousuf

evermore 03-08-2018 02:53 PM

2 Attachment(s)
Quote:

Originally Posted by PSk (Post 8101634)
No I was not talking about the front bumper but the swage/body line/crease that runs from the back of the car through the doors and front guard panel.

It should meet the top of the guard line and the run along the top most line of the nose panel. Yours does not ...
Pete

I am amazed you noticed this. Could it be that the car has after market wings? I am putting side by side pictures with a car that sold on BaT recently...

PSk 03-08-2018 03:04 PM

649 Attachment(s)
Quote:

Originally Posted by evermore (Post 8101826)
I am amazed you noticed this. Could it be that the car has after market wings? I am putting side by side pictures with a car that sold on BaT recently...

I was just about to do exactly what you have done.
Re noticing this ... unfortunately during my cars restoration process I've now become er, very aware of the little details of these shells. But I will admit that I put down my morning cup of tea and went for a trip to my shed to have a look at the front of my 1750GTV before posting <img src="http://www.alfabb.com/bb/forums/images/smilies/smile.gif" border="0" alt="" title="Smilie" class="inlineimg" />


I hate being bearer of bad news but our Alfista colleague needs to know so they can decide what to do about it, if anything. Note also the openings below the grill. I suspect she has had a significant hit in the front and the panel beater has used a considerable amount of filler during the fix and either was not an Alfa Romeo expert or did not have a car to compare against as the filling was done. Somewhere along the repair process the correct orientation of the side swage was lost.

But as we all know there is no need to despair as new front panels are available or heck some reshaping of the filler will make an improvement <img src="http://www.alfabb.com/bb/forums/images/smilies/smile.gif" border="0" alt="" title="Smilie" class="inlineimg" />
Pete

evermore 03-08-2018 03:21 PM

1 Attachment(s)
Quote:

Originally Posted by PSk (Post 8101850)
I was just about to do exactly what you have done.
Re noticing this ... unfortunately during my cars restoration process I've now become er, vefy aware of the little details of these shells. But I will admit that I put down my morning cup of tea and went for a trip to my shed to have a look at the front of my 1750GTV before posting :)


I hate being bearer of bad news but our Alfista colleague needs to know so they can decide what to do about it, if anything. Note also the openings below the grill. I suspect she has had a significant hit in the front and the panel beater has used a considerable amount of filler during the fix and either was not an Alfa Romeo expert or did not have a car to compare against as the filling was done. Somewhere along the repair process the correct orientation of the side swage was lost.

But as we all know there is no need to despair as new front panels are available or heck some reshaping of the filler will make an improvement :)
Pete

44 year old cars tend to have their secrets eh? Well I'm glad you noticed! As you will see from the attached photo, it looks like the second pair of openings below the bumper is entirely missing. Not sure what I'll do about this, if it does not affect the car mechanically. I do need to see if there is other evidence of an impact and if it has been repaired properly.

1978alfa 03-08-2018 03:38 PM

Agree. They all have secrets at this age.
My '74, the steering was very worn and unstable when I hit the brakes at any speed over 50 MPH.
I had a local reputable tire center rebuild the front end.
I supplied them with Centerline's front end rebuild kit with the adjustable upper control arms.
Between parts and labor, I spent about $1500 but it was well worth it.
I also added Centerline's sport coils which lowered the car an inch and made it handle better.
Another secret I found was the previous owner had hung the
fuel pump right over the rear exhaust arch with a zip tie!
Anyway, keep us posted on your progress!

-Clark

Alfajay 03-08-2018 03:46 PM

Quote:

Originally Posted by evermore (Post 8101434)
As for the coil, attached is a picture of the coil I took yesterday, will try to get more detailed shots..

Wow, I have to admit that the rear coil spring does look broken - never seen that before! My guess is that this car spent a lot of time in a damp environment - not in California - and that corrosion killed the spring. I wouldn't drive it that way.

Quote:

Regarding the brakes, I did not notice some huge pull to one side or another. Steering was a bit vague but I figure that is because of ancient bushings.
Brakes pulling to one side suggests a stuck caliper (or calipers).

The vague steering could be a lot of things, including a cracked steering box case. Steering is sort of important - again, I wouldn't drive it until this has been diagnosed and fixed.


All times are GMT -7. The time now is 02:43 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2002-2011 AlfaBB.com All Rights Reserved.

 
For the best viewing experience please update your browser to Google Chrome