Fresh air hoses - Alfa Romeo Bulletin Board & Forums
 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 07-18-2019, 12:09 AM Thread Starter
Registered User
 
Bertybuoy's Avatar
 
Join Date: Jul 2018
Location: Bath and Birgu
Posts: 12
Fresh air hoses

Hi All,
I have recently bought a couple of hoses to fit under the bonnet of my 1959 Giulietta 750D Spider, which duct air from the grill to the drivers side (under the steering wheel) and onto the back of the heater matrix.
I seem to have the incorrect length (despite having thought I bought the right parts!) so can anyone advise if either I’m doing something wrong or what the correct length should be?
Thanks in advance 👍
(Didn’t realise that I can’t upload videos to show, and only have one ‘still’ photo!)
Attached Images
 
Bertybuoy is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 07-18-2019, 11:05 AM
Darth Moderator
Platinum SubscriberModerator
 
AlfistiSA's Avatar
 
Join Date: Nov 2003
Location: Port Elizabeth, South Africa
Posts: 3,347
Who did you buy them from ??

Ciao
Greig

Some 750's
Some 101's
Some 105's
Some others
AlfistiSA is offline  
post #3 of 17 (permalink) Old 07-18-2019, 02:29 PM Thread Starter
Registered User
 
Bertybuoy's Avatar
 
Join Date: Jul 2018
Location: Bath and Birgu
Posts: 12
Bertybuoy is offline  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 07-19-2019, 04:03 AM
Darth Moderator
Platinum SubscriberModerator
 
AlfistiSA's Avatar
 
Join Date: Nov 2003
Location: Port Elizabeth, South Africa
Posts: 3,347
Classic Alfa generally have their act together, is the hose too short or two long ??

As a general rule they are a PITA to get through the oval holes in the inner wings & any 'hanging up' here could result in the hose seemingly being too short

Ciao
Greig

Some 750's
Some 101's
Some 105's
Some others
AlfistiSA is offline  
post #5 of 17 (permalink) Old 07-19-2019, 11:37 AM Thread Starter
Registered User
 
Bertybuoy's Avatar
 
Join Date: Jul 2018
Location: Bath and Birgu
Posts: 12
Too long... we have tried to compress the spring, but they still either obstruct the tyres or are too long to fit under the bonnet... it looks as though they are about 350mm too long.
Bertybuoy is offline  
post #6 of 17 (permalink) Old 07-19-2019, 12:39 PM
Darth Moderator
Platinum SubscriberModerator
 
AlfistiSA's Avatar
 
Join Date: Nov 2003
Location: Port Elizabeth, South Africa
Posts: 3,347
That sounds like the LHS Veloce hose which feeds from the LHS air collector to the air cleaner can - it's the longest hose, The others are shorter.

Alfastop give the 3 lengths as 600, 800 & 1100mm --> https://www.alfastop.co.uk/cgi-bin/p...ewDispCount=50

If memory serves correctly...

600 is the RHS hose to the heater
800 is the LHS hose to the driver's knee
1100 is the Veloce air can feed pipe

Dave B / Bill G - any corrections ??

Ciao
Greig

Some 750's
Some 101's
Some 105's
Some others
AlfistiSA is offline  
post #7 of 17 (permalink) Old 07-22-2019, 04:56 AM
Registered User
 
Join Date: Jul 2006
Location: Detroit Metro
Posts: 347
800 mm both sides.

Joe
jkbartusek is offline  
post #8 of 17 (permalink) Old 07-22-2019, 05:19 AM
Registered User
 
giuliettaspyder's Avatar
 
Join Date: May 2015
Location: Port Elizabeth, South Africa
Posts: 99
Both 800mm on my 101
giuliettaspyder is offline  
post #9 of 17 (permalink) Old 07-22-2019, 10:05 AM
Darth Moderator
Platinum SubscriberModerator
 
AlfistiSA's Avatar
 
Join Date: Nov 2003
Location: Port Elizabeth, South Africa
Posts: 3,347
There you go, 800mm on both sides... my memory obviously isn't that good

Aye
Greig

Some 750's
Some 101's
Some 105's
Some others
AlfistiSA is offline  
post #10 of 17 (permalink) Old 07-22-2019, 11:36 AM Thread Starter
Registered User
 
Bertybuoy's Avatar
 
Join Date: Jul 2018
Location: Bath and Birgu
Posts: 12
So it appears that I have the right hoses then?
I have tried to compress them to make a better fit, but with little effect! There was a very small part of the original duct on one side and seemed not to have such a rigid construction- it was almost paper like, with corrugated ridges... much easier to manipulate I’m sure.
Any suggestions on how I should proceed?
Thanks again,
Roy
Bertybuoy is offline  
post #11 of 17 (permalink) Old 07-22-2019, 12:36 PM
Registered User
 
Join Date: Jul 2006
Location: Detroit Metro
Posts: 347
Roy,
Are you having problems on both sides of the car?
Do you have the U shaped collar on the right side?
Joe
jkbartusek is offline  
post #12 of 17 (permalink) Old 07-22-2019, 12:52 PM Thread Starter
Registered User
 
Bertybuoy's Avatar
 
Join Date: Jul 2018
Location: Bath and Birgu
Posts: 12
Hi Joe,
Yes, they’re both looking as if they are too long. I have one of the U clamps that will retain the duct in the wheel arch so that they don’t interfere with the wheels/tyres, and when being used there seems to be an excess in the engine bay.
I’m tempted to cut the duct, but that would really spoil the beautifully moulded ends that make a neat fit over the spigots.
Bertybuoy is offline  
post #13 of 17 (permalink) Old 07-22-2019, 01:52 PM
Registered User
 
giuliettaspyder's Avatar
 
Join Date: May 2015
Location: Port Elizabeth, South Africa
Posts: 99
Greig

As usual your memory is correct. According to the parts manual, Veloces do have the three different sizesyou list.

But it also says Normales have two the same length.... but does not give an actual length.

Bertybuoy
You say they appear 350mm too long. What is the length of the hoses you have bought?
I am guessing that you have purchased two 1100mm ones because 1100-350 is 750mm close enough to what we think is correct.

Mike
Attached Images
 
giuliettaspyder is offline  
post #14 of 17 (permalink) Old 07-22-2019, 02:51 PM Thread Starter
Registered User
 
Bertybuoy's Avatar
 
Join Date: Jul 2018
Location: Bath and Birgu
Posts: 12
Hi Mike,
They are both the same length... I ordered 800mm, but they are definitely longer than that.
Maybe I have received the incorrect parts?
Bertybuoy is offline  
post #15 of 17 (permalink) Old 07-22-2019, 03:15 PM
Registered User
 
giuliettaspyder's Avatar
 
Join Date: May 2015
Location: Port Elizabeth, South Africa
Posts: 99
That's my guess
giuliettaspyder is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome