rumble in alfa spider - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-19-2012, 09:09 AM Thread Starter
Registered User
 
Join Date: Apr 2010
Location: seattle
Posts: 247
rumble in alfa spider

Hi,
Not sure where to post this question, hope this forum is not too wide of the mark. I have a spider, 1974, weber conversion. have noticed a rumbling vibration that occurs on deceleration, I can feel it in my feet transmitted through the driver floor pan. I get the impression that it might also be there when I engage the clutch, but only very brief vibration then, mostly it occurs when I take the foot off the accelerator. It seems worse when driving over bumps. I have looked as best I can under the car, can't see any point where the exhaust or mechanical parts are touching the body of the car.

Does anyone have any idea what the source might be? I wonder if the top of the transmission is too close to the transmission tunnel...

Thanks for any suggestions, or ideas about how to track it down.

TS
third spider is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-21-2012, 02:36 AM
Registered User
 
spiderserie4's Avatar
 
Join Date: Jul 2011
Location: Cologne, Germany
Posts: 7,190
Worth checking if the engine mounts are worn. Worn engine mounts allow too much twist and the breathers on top of the transmission can knock against the steel cover over the shifter tunnel...and usually you find the 3 rubber bellows on top are torn to bits. (you need to take out the centre console to inspect these, not a bad job to do)
Had a similar sounding problem, changed mounts and problem was gone.

Dom - Alfa Spider 1990 S4 - formerly: Alfa 101 Sprint, 2600 Sprint, Montreal - family classics: Jensen Interceptor II, '58 Hooper RR Silver Cloud I, Shadow II, '60 Corvette.
spiderserie4 is online now  
post #3 of 3 (permalink) Old 05-21-2012, 05:41 AM Thread Starter
Registered User
 
Join Date: Apr 2010
Location: seattle
Posts: 247
Thanks for the idea, this sounds like the place where the noise is coming from. However, the engine mounts were replaced about 2 years ago and the car is not driven very often, do you think they could wear so rapidly?

TS
third spider is offline  
Reply

Tags
deceleration, rumble, spider 1974

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome