105 Series 2L Spica - not idling, revs fine - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-12-2019, 08:29 AM Thread Starter
Registered User
 
Join Date: May 2018
Posts: 24
105 Series 2L Spica - not idling, revs fine

Freshly rebuilt motor with new starter
It turns over, fires and runs wall as long as the throttle is held to ~2500 rpm
When the revs are allowed to drop, it dies when trying to idle
It's not fueling or ignition issue as it revs freely and smoothly
Seems to be a Spica idle adjustment or vacuum hose issue perhaps

What are the easy fixes / trouble shoots?

Thank you
alfisti berlin is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-12-2019, 05:54 PM
Quote:
Originally Posted by alfisti berlin View Post
Freshly rebuilt motor with new starter
It turns over, fires and runs wall as long as the throttle is held to ~2500 rpm
When the revs are allowed to drop, it dies when trying to idle
It's not fueling or ignition issue as it revs freely and smoothly
Seems to be a Spica idle adjustment or vacuum hose issue perhap

What are the easy fixes / trouble shoots?

Thank you
I just pulled my 2L out of winter storage and had the problem. It turned out to be bad gas and poorly gapped plugs. Runs great now.

That said, I'd recommend going thru the SPICA setup step by step to make sure you're where you should be.

The Brad Davisson Memorial Scholarship Fund:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Last edited by gprocket; 05-24-2019 at 07:31 PM.
gprocket is offline  
post #3 of 3 (permalink) Old 05-24-2019, 05:15 PM
Registered User
 
r-mm's Avatar
 
Join Date: Jan 2010
Posts: 3,340
You will find lots of SPICA step by step guides they are important to follow. I will add to this: check the maligned and overlooked o-ring in the air tower. The forum wisdom seems to be it does nothing but I solved my SPICA dying at idle problem with a plump fresh oring that let me control idle air and lean out mixture.

That said not idling below 2500 sounds like you are very lean or have lots of air leaking. Check throttle bodies, brake booster. What do the plugs look like ?

'73 GTV bare metal project... nearing 'car' status
E30 Daily - '65 912 project... no longer in waiting
r-mm is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
My suggestion to American Alfisti who want a manual Guilia PSk Giulia (2017-current) 45 06-17-2017 05:02 AM
Email from Reid Bigland regarding the lack of manual in the US James Locopo Giulia (2017-current) 34 11-07-2016 04:33 AM
Can anyone list the differences between a 105 Series 1 and a 105 Series 2 please. carbon8 Australian Forum 41 03-02-2016 05:21 AM
My 1750 Bella - Rebuilding a Series 2 105 1750 GT Veloce Coupe carbon8 GT (1963-1977) 46 01-09-2011 07:27 PM
Buying a spider Gene Cricco Spider - 105 & 115 Series (1966-1994) 27 04-08-2007 06:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome