1990 motronic spyder - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-13-2014, 04:22 PM Thread Starter
Registered User
 
Join Date: Mar 2011
Posts: 9
1990 motronic spyder

I have a spyder at my shop that is running rich at idle after customer changed fuel lines to the injectors. Checked the VVT solenoid, worse idle when powered. Checked the air flow meter for free movement, cleaned water temp senders, fuel pressure is 44 lbs and 50lbs with vacuum line off pressure regulator. All plugs are black. Can not check for individual flow rates on injectors as fuel pressure drops when turned off, guessing it is a bad check valve in pump as blocking the return line past regulator didn't change pressure drop. I have 2 questions. Has anyone seen this problem? Do you know the resistances of temp sender in head and air flow meter? Can you check for codes as on a 164? The factory manual doesn't address any of these questions. I guess I will need to send car to the former dealer. Thanks Will Jamison, Will's Imports
WJamison is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-13-2014, 04:24 PM Thread Starter
Registered User
 
Join Date: Mar 2011
Posts: 9
I am just checking to see if I can get a reply. Will Jamison
WJamison is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome