HELP! Alfa 1.9 diesel in 'limp mode' - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-04-2014, 04:25 AM Thread Starter
Registered User
 
Join Date: Jun 2014
Posts: 1
HELP! Alfa 1.9 diesel in 'limp mode'

Hi all....can someone kindly help me with understandable answers/repair instructions!
2004 1.9 diesel sportwagon. Parked up, when we came back engine refused to exceed 1500 revs, and exhaust smoking a little.
Managed to get it home, and understand likely dirty sticking components. Problem is that an Alfa garage is quite a way from me.
Please can someone kindly advise me as to how to,put it right and where I can locate the components under that wonderful huge plastic cover.........
Thank you. Freddie
carrotsucker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome