What's wrong with this picture? - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-22-2010, 08:11 PM Thread Starter
Registered User
 
Biba69's Avatar
 
Join Date: Apr 2005
Location: Irwindale, CA USA
Posts: 3,476
What's wrong with this picture?

Again I want to say that if I get another L-Jetronic car in, I'll get the necessary manual - though do have one for the GVT6/Milano.

This can't be right (variable cam hardware) since there was obviously something that was up against the hole above what I'll term the valve.

Should it be correct: (a) what does that empty hole do or is for? (b) what holds the gold metal plate in place...glue? (c) there wasn't a gasket on the solenoid unit was there?

I did remember the valve's O-ring.

Sorry to ask these details.

Biba
Attached Images
 
Biba69 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-23-2010, 03:37 AM
Registered User
 
kredden's Avatar
 
Join Date: Jul 2003
Location: North Bend, WA
Posts: 3,325
Hope this helps.

Kevin
Attached Images
 

Currently Alfaless. Ex: 87 Verde, 86 GTV6, 67 Super, 86 Spider, 88 LeMons Verde
Milano registry custodian(
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
)
kredden is offline  
post #3 of 4 (permalink) Old 11-23-2010, 03:50 AM
Trained (ex)Professional

1953-2018 RIP

Platinum SubscriberAdministrator
 
papajam's Avatar
 
Join Date: Feb 2003
Location: New Jersey USA
Posts: 16,232
A) the empty hole is one of two threaded holes for the flathead machine screws that hold on the plastic sparkplug wire holder
B) the gold metal plate is held in with a (currently missing) allen head bolt
C) no gasket

D) the solenoid plunger is in backwards; the 'disc' goes on the inside of cam cover

Jim

Series 2 USA 1750 GTV (in Series 1 European clothing)
papajam is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 11-23-2010, 11:40 AM Thread Starter
Registered User
 
Biba69's Avatar
 
Join Date: Apr 2005
Location: Irwindale, CA USA
Posts: 3,476
Thanks Jim and Kevin. Call me crazy, but the diagam seems to definitely show the plunger and O-ring in the upper hole and the screw in the lower one. I scratched my head and thought that somethng was definitely amiss here.

I found this photo (tiny section of the entire engine) and then physically duplicated it, screw on top, plunger and O-ring (will be) in the lower hole.

On another note, thanks Jim for the reminder regarding the sparkplug wire holder. I just checked and the new Magnor wires won't fit inside. Sure wish they made a slightly larger wire holder.

Biba
Attached Images
   
Biba69 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome