Ignition timing. - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-20-2010, 06:43 PM Thread Starter
Registered User
 
Biba69's Avatar
 
Join Date: Apr 2005
Location: Irwindale, CA USA
Posts: 3,477
Ignition timing.

This definitely falls under 'having a duh moment' catagory. For the past several months my Alfetta GT (dual Webers, Euro inlet, air box and cleaner, 10-1 pistons) has idled better than it ever has, but thought I'd check the timing. I'll add here that I have a MarelliPlex with a Jim Steck modified advance mechanism. With idle at about 1K (engine was cold so used hand throttle) and timing light set at 0, it was running about 12 degrees After TDC.

My thought was that I didn't want to screw up that nice idle, but it obviously needed to be advanced a fair amount. I'm now going to mix apples with oranges - in that my final 'run' with the engine at around 3.5K, and the timing light set at 35 degrees, the light lined up with TDC.

I haven't taken it out for a run yet, but it seemed to idle nicely with a now warm (not hot) engine.

More advance? I'm doing it all wrong? Yes, I visually checked the advance mechanism and it looked fine.

Biba
Biba69 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-20-2010, 06:55 PM
Supporting Vendor
 
JoeCab's Avatar
 
Join Date: Dec 2002
Location: Colorado
Posts: 4,327
Quote:
Originally Posted by Biba69 View Post
More advance? I'm doing it all wrong? Yes, I visually checked the advance mechanism and it looked fine.
35 degrees max advance should work nicely at sea level, unless the engine pings under load, in which case you can back off a bit.

Centerline International - Alfa Romeo Parts & Accessories

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
750-ALFA
JoeCab is offline  
post #3 of 3 (permalink) Old 11-21-2010, 06:25 PM Thread Starter
Registered User
 
Biba69's Avatar
 
Join Date: Apr 2005
Location: Irwindale, CA USA
Posts: 3,477
Joe, I'm sure you're aware that the MarelliPlex has a very short degree of advance - 12 degrees. The Shankle mod brings/brought it up to 17 degrees. So you won't be surprised when I double checked today that at 850 idle, the pointer was roughly 17 degrees from the 36 degree mark. The Alfetta didn't like it, didn't ping but would do brief cutting out when revving, getting worse once fully warmed up.

Bottom line after several retarding of the dist.and testings I ended up with the pointer at the 6 degree advance mark at 850 rpm. However, when I set the timing light on 25 (degrees) and revved it to roughy 3.5K (or more) it ended up on the same spot - 6 degrees (BTDC).

I'll add that I added a second washer to the spark plugs. I was (still might be) getting blow by through the spark plug hole and had the plugs tightened as much as I was comfortable with. I can't beleive that would have any effect to the car's running.

I'm still not completely happy with the results, but for now will drive it and make incremental adjustments if I feel they're needed.

Biba
Biba69 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome