twin spark conversion - Page 2 - Alfa Romeo Bulletin Board & Forums
Reply
 
LinkBack Thread Tools Display Modes
post #16 of 20 (permalink) Old 05-02-2018, 06:21 AM
Registered User
 
iachella's Avatar
 
Join Date: Sep 2005
Location: Concord, CA
Posts: 2,165
Thanks for the offer, Stephen. You can send me a private message or email if you find the harness. Email address bellow my signature.

Ian - I too have an Emerald installed in my twin spark. I'd like to communicate offline with you too, if that's OK. I'm still tuning so I have some questions for the more experienced.

Thanks,

Stefano
Concord, CA
iachella [at] gmail [dot] com
iachella is online now  
Sponsored Links
Advertisement
 
post #17 of 20 (permalink) Old 05-02-2018, 11:55 AM
Registered User
 
hunttheshunt's Avatar
 
Join Date: Mar 2012
Location: Western Germany
Posts: 1,031
Quote:
Originally Posted by ianellisalfa
For me a twinspark on original EFI just doesn't sound like an Alfa!
Exactly, Ian. Sounds like an Opel.

R.I.P. Alfa Romeo 1910 - 1986. 1987---> Badge engineering since then.
hunttheshunt is offline  
post #18 of 20 (permalink) Old 05-03-2018, 09:59 AM
Registered User
 
kpc655's Avatar
 
Join Date: Mar 2009
Location: Clarkston, MI
Posts: 1,226
My race ts head made peak power around 24 deg total advance. 28 sounds quite high
kpc655 is offline  
Sponsored Links
Advertisement
 
post #19 of 20 (permalink) Old 05-04-2018, 02:22 AM
Registered User
 
Veep's Avatar
 
Join Date: Mar 2005
Location: Overasselt, The Netherlands
Posts: 1,134
Quote:
Originally Posted by kpc655 View Post
My race ts head made peak power around 24 deg total advance. 28 sounds quite high
I have to check what the advance is set at now. but for sure way less than 28 degr. The first dyno guy (a inexperienced one it appeared with TS engines...new guy in the shop, old one took the plunge to be self employed) had it at that and that allmost ruined my new engine..(besides some other ploblems that had to be taken care off)
Veep is offline  
post #20 of 20 (permalink) Old 05-30-2018, 08:23 AM
Registered User
 
kpc655's Avatar
 
Join Date: Mar 2009
Location: Clarkston, MI
Posts: 1,226
I'm currently working to port another head and set it up for 48's. Should add some RPM and HP....it'll be back on the dyno towards the end of summer.
kpc655 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome