No power windows, winshiled wipers etc - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-11-2019, 12:06 AM Thread Starter
Registered User
 
Join Date: Jul 2019
Posts: 4
No power windows, winshiled wipers etc

My 166 3.0 super -99 have an irritating electric fault. I’ve been troubleshooting for months. Windscreen vipers, power windows, central locking, potentiometer and radio is’nt working. Have replaced fuses, relays, fusebox and power window control units, checked earths but no luck. Have been through eLearn and AlfaEcuScan but can’t find the source of the problem. Anybody out there that has a clue?
Tomik is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-11-2019, 03:45 AM
Registered User
 
Ranz's Avatar
 
Join Date: Dec 2009
Location: Hobart Tasmania
Posts: 1,042
Can’t be definitive here, but after much head scratching, and with little help from wiring diagrams etc, my son has just traced a similar set of missing electrical devices (instruments, too) to a 10A fuse for ‘ignition-switched-electrical devices’ (servizi vario in 105 speak, but the 164s still do it that way too) in his 3.0 GTV. A relay does this circuit, it seems, but there’s a fuse in there too, so keep checking fuses everywhere. Too much of a coincidence to have so many items out of commission.
Ranz is offline  
post #3 of 7 (permalink) Old 07-11-2019, 04:06 AM Thread Starter
Registered User
 
Join Date: Jul 2019
Posts: 4
Tomik

Thanks, yes, it could be a built in fuse in one of the relays, like the R1. This gives me a new approach.
Tomik is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 07-11-2019, 04:37 AM
Registered User
 
Ranz's Avatar
 
Join Date: Dec 2009
Location: Hobart Tasmania
Posts: 1,042
Sorry, Perhaps I could have phrased it better, but the dead fuse wasn’t ‘inside’ the relay on that circuit, but additional. And he found this one after saying “yes dad, I checked the fuses’. It seems different models have fuses in different places.
Ranz is offline  
post #5 of 7 (permalink) Old 07-11-2019, 04:43 AM Thread Starter
Registered User
 
Join Date: Jul 2019
Posts: 4
Italian magic.
"-Guiseppe, we need another extra fuse for the devices"
-"Bene, I put one in somewhere under the dash"
Tomik is offline  
post #6 of 7 (permalink) Old 07-11-2019, 05:33 AM
Senior Member
Platinum Subscriber
 
Alfisto Steve's Avatar
 
Join Date: Dec 2003
Location: VB, VA
Posts: 26,494
Garage
Just an idea for you to ponder/check - on the 164 the ignition switch has 3 power contacts besides the 4th one for starter and one of those three that powers/operates many accessories is known to go dead. Have no idea how the 166 is set up.

Ciao, Alfisto Steve
Virginia Beach, VA
AROC 164 Tech Advisor

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

My Maintenance Sticky:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Alfa Semi-Daily driver: USA model - BB2 1991 164S Black Beauty II ALFISTO [U]

[U] BB1 1991 164L w/S engine and A/T now excess to inventory [U]

Daily driver and parts hauler but not car hauler 2004 Jeep Grand Cherokee Overland 4.7L H.O. V-8

"A day without an Alfa whine is like a day without sunshine"
Alfisto Steve is offline  
post #7 of 7 (permalink) Old 07-11-2019, 06:59 AM Thread Starter
Registered User
 
Join Date: Jul 2019
Posts: 4
Tomik

Looking at eLearn, all of the not-working devices seems to be at socket A on the backside of the fusebox. Allthough I changed fusebox, if there is no power from the ignition switch, nothing will happen. I will try to put 12V directly to the pins of the unplugged socket to see if they are activated or not.
Tomik is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome