1968 1750GTV Speedometer not working - Alfa Romeo Bulletin Board & Forums
 1Likes
  • 1 Post By Gubi
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-17-2019, 08:34 AM Thread Starter
Registered User
 
Join Date: May 2014
Posts: 3
1968 1750GTV Speedometer not working

Hi guys, I have the above car, the speedo is completely dead, but the odometer and trip work ok. As does the lighting and regeneration etc lights.

Any ideas? I'm baffled as the counter works.

Cheers

Sent from my SM-G960F using Tapatalk
911F is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-17-2019, 09:12 AM
But Mad North-Northwest
Platinum Subscriber
 
Gubi's Avatar
 
Join Date: Sep 2003
Location: SF Bay Area, CA
Posts: 9,615
It's not the cable, then, so something is internally broken. Suspect you'll need to pull the head and send it to a speedo shop for repair.
911F likes this.

Tom

1963 Giulia Spider (1750 engine)
1974 GTV
1991 Spider
Former: 1987 Milano Gold
Gubi is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome