trunk won't open, car won't start - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-04-2019, 07:27 PM Thread Starter
Registered User
 
Winston's Avatar
 
Join Date: Apr 2007
Location: Pennsylvania
Posts: 9
trunk won't open, car won't start

1989 Alfa Romeo Spider. I cannot get the latch to open the trunk. I have read that you can start from the engine, how is that done? Other solutions? I have looked.
Winston is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-06-2019, 10:48 AM
Darth Moderator
Platinum SubscriberModerator
 
AlfistiSA's Avatar
 
Join Date: Nov 2003
Location: Port Elizabeth, South Africa
Posts: 3,286
There has to be a reason why the latch won't open the trunk, normally the cable slips a bit in either the lever or the lock.

Tip the seats forward, remove the rear trim panel to gain access to the cable. Remove the handle and using a pair of pliers try to pull the cable manually.

Let us know what happens

Ciao
Greig

Some 750's
Some 101's
Some 105's
Some others
AlfistiSA is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome