Montreal Horn Wiring Issue - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-22-2019, 11:00 PM Thread Starter
Registered User
 
Kiwi Veloce's Avatar
 
Join Date: Sep 2010
Location: Auckland, New Zealand
Posts: 27
Montreal Horn Wiring Issue

Hi,

The horn on my Montreal has stopped working and I have traced it to a bad connection on the Blue wire to the horn ring. The weird thing is when I activate the horn ring the wire moves but no connection. I have run a temporary wire from the black earth wire to the ring and lo and behold the horns work.

Question is - is there anyway I can check the blue wire connection or replace it WITHOUT having to take the steering wheel off?

Help appreciated.
Attached Images
 

69 1750 Veloce Spider Road/Race
1974 Montreal and 2004 156 Ti
Kiwi Veloce is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-23-2019, 05:24 AM
USTA BE AN AD-MIN
Platinum SubscriberAdministrator
 
ossodiseppia's Avatar
 
Join Date: Oct 2003
Location: Broomfield, Colorado U.S.A
Posts: 11,010
Garage
As you well know, the horn "buttons" only act as a ground when they are pushed. Somewhere behind the center of the wheel, you're not getting that connection. If you've checked the blue wire for continuity with ground, then you'll need to pull the steering wheel.

I have a similar issue with the steering wheel on my car. Two of the "buttons" work and the third does not. It's not a priority at the moment, but I'll need to remove the steering wheel to investigate.

Brian __________________________________
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
ossodiseppia is online now  
post #3 of 4 (permalink) Old 05-23-2019, 01:46 PM
Senior Member
Gold Subscriber
 
Join Date: Dec 2006
Location: 592 Browns Trace Jericho, Vermont
Posts: 2,589
Garage
Maybe the wire by the steering box? they break.

AlfasRule!

1972 Montreal (The Pumpkin)
1975 Alfetta Sedan
1975 Alfetta Coupe Race Car
1982 Spider
1984 GTV-6
1984 GTV-6 Verde (GiGi)
1987 Milano (Da NEW Winta Beata)
1987 Milano Verde(Da kREDden Mobile)
alfasrule is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 05-24-2019, 05:11 PM
Registered User
 
r-mm's Avatar
 
Join Date: Jan 2010
Posts: 3,339
Ground the blue wire to known good ground. Honk or no honk? It runs to the horn relay thru the steering column, box.

Other wire is soldered to ring on wheel and i would guess more likely the culprit.

If anything the failure mode of the blue wire is likely nonstop horn. Name:  IMG_6460.jpg
Views: 10
Size:  161.5 KB

'73 GTV bare metal project... nearing 'car' status
E30 Daily - '65 912 project... no longer in waiting
r-mm is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Montreal Horn Relay alfajp Alfa Romeo Montreal 17 12-22-2015 07:58 AM
Montreal door Gasket fitment issue IRONBLOCK Alfa Romeo Montreal 4 09-11-2015 05:54 AM
Montreal Starter Solenoid Wiring Question alfajp Alfa Romeo Montreal 4 07-06-2015 04:24 AM
Horn Wiring rshirer Milano/75 (1985-1993) 0 03-31-2012 05:24 PM
79 Spider Horn Wiring alfafan61 Spider - 105 & 115 Series (1966-1994) 1 01-14-2009 06:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome