87 Spider issue with spoiler brake light - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-25-2019, 09:48 AM Thread Starter
Senior Member
Gold Subscriber
 
spiderJohnNH's Avatar
 
Join Date: Jul 2015
Location: Southern NH (Nashua area)
Posts: 355
Garage
Send a message via Yahoo to spiderJohnNH Send a message via Skype™ to spiderJohnNH
87 Spider issue with spoiler brake light

Hi gang -

In today's 'It's always something department' -- My Spider failed state inspection last week. Results were fine except . . .
In the trunk lid, the 3 license plates lights and the third brake light in the spoiler were all non-op.

I cleaned the contacts on the body and trunk lid and the license plate lights work fine now, and the spoiler mounted light is on when lights are on . . .

The remaining problem is that the brake light does not change when brakes are pressed - so the second, hi voltage filament is not lighting up.

I swapped the bulb with the brake light, dual filament bulb in the left brake light position. The left brake light still works (so the bulb is good), but there is no change with the spoiler mounted brake light.

Anyone have any BTDT experiences or suggestions to offer?

John

John R
So. NH, USA --'87 Spider Veloce
See you along the road - member of AROC/AONE

other current members of the fleet

2017 VW Jetta Tsi
2006 Subaru Outback - almost a driveway requirement in VT & NH
2007 Toyota Corolla

previous
2009 VW Jett TDi (Deer took this one out)
1984 Mercedes 300TDT wagon, rust took that one
1972 Mercedes 280SE, got in straight swap for the Discovery
1996 Land Rover Discovery
1986 Volvo 740 Turbo Wagon
1962 VW Bug - 6 volt
1974 Triumph Spitfire - wobbly driveshaft kept destroying stuff
1972 Triumph Spitfire - got totaled while parked at DMV

some others that were less interesting
spiderJohnNH is online now  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-25-2019, 10:21 AM
BB Janitor
Platinum SubscriberAdministratorSuper Moderator
 
ghnl's Avatar
 
Join Date: Oct 2005
Location: Mebane, NC
Posts: 16,272
Garage
I have an earlier model Spider so no experience with the later Spider's center brake light. But, are you sure it is supposed to illuminate with the lights on? I thought it was a brake light only. Peek inside the lamp sockets - are there one or two contacts? If one then it would use single filament bulbs.

- - Eric
don't read this
~ 1984 Spider Veloce ~
- -~ 1981 GTV-6 ~
Mebane, North Carolina


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
ghnl is online now  
post #3 of 4 (permalink) Old 05-11-2019, 11:05 AM Thread Starter
Senior Member
Gold Subscriber
 
spiderJohnNH's Avatar
 
Join Date: Jul 2015
Location: Southern NH (Nashua area)
Posts: 355
Garage
Send a message via Yahoo to spiderJohnNH Send a message via Skype™ to spiderJohnNH
Solved. Took the plate off the body side. One of the three spade connectors was disconnected and damaged. It was the center connector, black wire. Cleaned the connectors while it was all apart. Used some electrical tape to give it a better grip. All good now.

Sent from my SM-T710 using Tapatalk

John R
So. NH, USA --'87 Spider Veloce
See you along the road - member of AROC/AONE

other current members of the fleet

2017 VW Jetta Tsi
2006 Subaru Outback - almost a driveway requirement in VT & NH
2007 Toyota Corolla

previous
2009 VW Jett TDi (Deer took this one out)
1984 Mercedes 300TDT wagon, rust took that one
1972 Mercedes 280SE, got in straight swap for the Discovery
1996 Land Rover Discovery
1986 Volvo 740 Turbo Wagon
1962 VW Bug - 6 volt
1974 Triumph Spitfire - wobbly driveshaft kept destroying stuff
1972 Triumph Spitfire - got totaled while parked at DMV

some others that were less interesting
spiderJohnNH is online now  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 05-11-2019, 11:27 AM Thread Starter
Senior Member
Gold Subscriber
 
spiderJohnNH's Avatar
 
Join Date: Jul 2015
Location: Southern NH (Nashua area)
Posts: 355
Garage
Send a message via Yahoo to spiderJohnNH Send a message via Skype™ to spiderJohnNH
Here are pictures.



Sent from my iPhone using Tapatalk

John R
So. NH, USA --'87 Spider Veloce
See you along the road - member of AROC/AONE

other current members of the fleet

2017 VW Jetta Tsi
2006 Subaru Outback - almost a driveway requirement in VT & NH
2007 Toyota Corolla

previous
2009 VW Jett TDi (Deer took this one out)
1984 Mercedes 300TDT wagon, rust took that one
1972 Mercedes 280SE, got in straight swap for the Discovery
1996 Land Rover Discovery
1986 Volvo 740 Turbo Wagon
1962 VW Bug - 6 volt
1974 Triumph Spitfire - wobbly driveshaft kept destroying stuff
1972 Triumph Spitfire - got totaled while parked at DMV

some others that were less interesting
spiderJohnNH is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Giulietta/Giulia Spider Register pathung Giulietta & Giulia (1954-65) 553 05-17-2019 01:38 AM
'86 Spider 3rd Brake (Center) Light...Help Pls! Disaffect Electrical, Chassis & Lighting 1 12-31-2016 01:18 PM
Hello! Issue with third brake light socket gmilke Spider - 105 & 115 Series (1966-1994) 9 07-20-2013 03:25 PM
1990 Spider , Middle Brake Light Out Jloprete Electrical, Chassis & Lighting 0 02-19-2012 08:32 AM
WTB: S3 Spider Spoiler Brake Light Cover Alfa8486 Alfa Romeo Parts For Sale & Wanted 0 01-01-2008 06:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome