I did something stupid.... - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-13-2019, 01:36 PM Thread Starter
Registered User
Platinum Subscriber
 
SpiderMan59's Avatar
 
Join Date: Aug 2017
Posts: 28
Garage
I did something stupid....

Hi All,

A while back I had to jump my '92 Alfa Spider, but FORGOT to check the battery terminals, and I connected the little pocket jumper backwards, thereby frying that battery. I've since bought a new battery and the car runs ok, BUT....

1. Turn signal lights don't work
2. Car radio doesn't work (custom radio/CD player installed)
3. Radio antenna does not extend anymore.
4. There may be other electrical affects, but as yet unknown/undiscovered.

I'm hoping this is just a blown fuse(s) issue....I managed to check the fuses, and the one regulating the door alarm & radio circuit is ok, as the door alarm is working. I'll wait until it's dark to check the other fuses regulating lights.....


Is there a possibility of more extreme electrical damage from my IDIOT blunder?

Any help would be appreciated!
Thanks,
Jim

JimB in SoCal

Current Cars Owned: 1991 Alfa Romeo Spider Veloce!!!!, 2012 Buick Verano
Previous Cars Owned: 1956 Chevy Sedan, 1969 Chevy Caprice Sedan, 1973 Chevy Caprice Sedan, 2000 Saturn S1 Sedan.

Last edited by SpiderMan59; 04-13-2019 at 05:57 PM.
SpiderMan59 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Another stupid movie chase scene involving an Alfa xalfaracer Alfa Romeo Videos 3 11-04-2015 05:04 PM
Stupid is, stupid does Alfisto Steve Off-Topic Talk 0 09-16-2012 04:47 AM
Stupid Idea??? johnalfa1976 Alfa Romeo Topics Not Covered Elsewhere 12 10-23-2010 01:13 PM
Stupid, stupid mistake cargazing Spider - 105 & 115 Series (1966-1994) 14 08-08-2006 07:11 PM
You think YOU'VE been stupid? Ianc Spider - 105 & 115 Series (1966-1994) 22 12-16-2005 05:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome