Help-New turn signal assembly install - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-20-2018, 02:28 PM Thread Starter
Senior Member
Gold Subscriber
 
Crowbar44's Avatar
 
Join Date: Jun 2018
Location: Katy, TX
Posts: 130
Help-New turn signal assembly install

Hello all, I have a problem...

I have a 1981 Spider (Candadian Originally) and needed to replace the turn signal/wiper/headlight assembly due to a broken turn signal stalk and housing.

I ordered this new unit from Classic Alfa (Picture 1)

The colors of the wires on the new unit are for the most part completely different compared to the wiring diagram from Papajan. Only the Red, Yellow and Green wires on the headlight portion appear to be the same (Picture 2)

For the Headlight portion The Grey and Black/Grey wires that go to position 8 and 9 on the fuse box are instead Orange and Blue/Yellow on the new unit (Headlight portion of the assembly). (Picture 2)

On installation the Headlights and Taillights work fine...but I have no Wipers or Turn Signals

The colors for all the wires on the Wiper/Turn signal portion of the assembly are completely different, however, they all terminate at an 8-pin connector that only fits onto the harness in the car one way (see picture #3).

However, the new assembly has an additional set of wires on its own connector with 2 blue and 2 red wires, my old assembly did not have these wires, and I can see nowhere to attach them under the dash.

So after installation my Turn Signals and Wipers don't work, I had 2 thoughts:

1) The unit is bad (UNLIKELY)

2) The 8-pin connector is not wired correctly for my car and needs to be re-wired with a new 8-pin connector.

Does anyone have any insight? Unfortunately I wouldn't know where to start on re-wiring the 8-pin connector as the wiring colors are completely different.

Does anyone have a wiring diagram for this newer unit?


Any ideas on how to start troubleshooting this would be greatly appreciated.
Attached Images
   

'81 Spider (Weber's, Euro Bumpers, Custom Interior) Ivorio over Red | '54 Austin Healey 100-4, Bone Stock save for M cam, Carmine over Black.
Crowbar44 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-20-2018, 05:19 PM
USTA BE AN AD-MIN
Platinum SubscriberAdministrator
 
ossodiseppia's Avatar
 
Join Date: Oct 2003
Location: Broomfield, Colorado U.S.A
Posts: 11,023
Garage
Please don't view my reply as being smug.

If it were me, I would:

1) Contact the seller and ask for instructions.

If they shrug their shoulders then I would:

2)Use a multi meter to figure out which wires work the same way as the unit you removed from your car.

Brian __________________________________
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
ossodiseppia is online now  
post #3 of 3 (permalink) Old 07-20-2018, 06:01 PM Thread Starter
Senior Member
Gold Subscriber
 
Crowbar44's Avatar
 
Join Date: Jun 2018
Location: Katy, TX
Posts: 130
Osso - no smugness taken

Still waiting to hear from Classic Alfa...contacted them yesterday - but would appreciate any ideas...I highly doubt that the 8 pin is wired differently, but who knows.

'81 Spider (Weber's, Euro Bumpers, Custom Interior) Ivorio over Red | '54 Austin Healey 100-4, Bone Stock save for M cam, Carmine over Black.
Crowbar44 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome