Alfa Romeo Bulletin Board & Forums

Alfa Romeo Bulletin Board & Forums (https://www.alfabb.com/bb/forums/)
-   Electrical, Chassis & Lighting (https://www.alfabb.com/bb/forums/electrical-chassis-lighting/)
-   -   1986 S3 switch for reversing light (https://www.alfabb.com/bb/forums/electrical-chassis-lighting/662994-1986-s3-switch-reversing-light.html)

orangutangas 06-17-2018 12:45 PM

1986 S3 switch for reversing light
 
Hello,
I am trying to find a switch for reversing light for my S3 Spider. Reverse light does not have a signal while it goes up to transmission box. Is that switch inside transmission box or somewhere outside? I somehow struggling to find it while the car is not lifted. And Do you know if i have to disassemble gearbox to reach that switch or is it easily reachable?

sloboy89 06-17-2018 12:54 PM

Quote:

Originally Posted by orangutangas (Post 8269834)
Hello,
I am trying to find a switch for reversing light for my S3 Spider. Reverse light does not have a signal while it goes up to transmission box. Is that switch inside transmission box or somewhere outside? I somehow struggling to find it while the car is not lifted. And Do you know if i have to disassemble gearbox to reach that switch or is it easily reachable?

Switch is inside bell housing on front of gearbox. Transmission must be removed to replace the switch. Bad design.

orangutangas 06-17-2018 01:04 PM

Oh my...It will take some time. Do you know i have to buy a new better or is it possible to restore easily that not working switch?

spiderJohnNH 06-17-2018 01:08 PM

Many have commented that a switch failure is very rare. Usually, as in my experience, the connectors all need to be cleaned up. This is a common problem caused by corrosion as the wiring runs underneath exposed to the elements.

Are you sure that there is no signal in the wires coming out of the bell-housing?

Sent from my SM-T710 using Tapatalk

orangutangas 06-17-2018 01:15 PM

I will try once again to do a double check, bu spent almost whole weekend and haven't got that signal working and going to the end into rear light. And signal ends somewhere near transmission box..

sloboy89 06-17-2018 02:06 PM

Quote:

Originally Posted by orangutangas (Post 8269930)
I will try once again to do a double check, bu spent almost whole weekend and haven't got that signal working and going to the end into rear light. And signal ends somewhere near transmission box..

You should have two wires going into the bell housing. One of them should be hot with the key on. When the gearbox is put in reverse, that should close the switch mounted inside the bell housing. You should be able to diagnose whether the switch is working fairly easily.

With the car securely on jack stands, get underneath and find the connectors in the two wires (should be near the gearbox). Separate those connectors. With the key on (engine off), use a voltmeter to see if you have a voltage (~12V) between the pink wire on the car side and ground. If you don't, then your problem may not be the switch but rather may be a fuse (fuse 7?) or a broken wire. If you do have a voltage on the wire, then you need to check the switch.

To check the switch, put an ohm-meter across the two wires that go into the bell housing. (Again, do this with the car off). When the car is in reverse, the resistance should be very low, indicating a closed circuit. When the car is in neutral (or any gear other than reverse), the resistance should be infinite, indicating an open circuit. If it meets these tests, the switch is working.

If the car passes both of these tests but the reverse lights still don't work, it could be a faulty ground or burned-out bulbs. The reverse lights share a ground with the tail lights, so if those work but the reverse lights don't, that isn't likely.


All times are GMT -7. The time now is 01:11 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2002-2011 AlfaBB.com All Rights Reserved.

 
For the best viewing experience please update your browser to Google Chrome