Fuel pump will not go on - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-29-2018, 08:35 AM Thread Starter
Registered User
 
Join Date: Aug 2017
Location: Milford, CT
Posts: 75
Garage
Fuel pump will not go on

After my 78 spider running great, i tried to start it and did not hear the fuel pump run when key was in the MAR position.
It obviously did not start.
I assume that it is a bad ignition switch. I have one ordered from Alfaholics, however, does anyone have an in house fix to get it running before the new switch comes in.
I could really use a ride this week as the weather is great!!
Thanks
milford is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-29-2018, 08:58 AM
Trained (ex)Professional

1953-2018 RIP

Platinum SubscriberAdministrator
 
papajam's Avatar
 
Join Date: Feb 2003
Location: New Jersey USA
Posts: 16,232
Do the gauges and dash warning lights work when you turn the key? If so, the ignition switch is not the problem. I'd check the fuelpump fuse (it's in the small 2-fuse fusebox next to the large 10-fuse fusebox).

Jim

Series 2 USA 1750 GTV (in Series 1 European clothing)
papajam is offline  
post #3 of 3 (permalink) Old 05-29-2018, 09:00 AM Thread Starter
Registered User
 
Join Date: Aug 2017
Location: Milford, CT
Posts: 75
Garage
I checked all the fuses. all are good. the fuel pump goes on as i advance the key into the starter position. but when it returns, pump goes off.
I jumped the pump and it started right up.
milford is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome