iPhone photo problem - Alfa Romeo Bulletin Board & Forums
 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 09-04-2016, 09:45 PM Thread Starter
Registered User
 
oz3litre's Avatar
 
Join Date: Jul 2005
Location: Adelaide South Australia
Posts: 3,806
iPhone photo problem

Can you guys please put some effort into solving the problem of iPhone photos appearing upside down when trying to attach them? I have asked this before and nothing has been done. I find it unacceptable and am losing patience. It makes no difference with the orientation of the camera and rotating the pics before posting is ineffective. I am not interested in tricky workarounds and believe it is a software issue with the website and can be fixed if you put the right people on the job. Please do so.

Current Alfas
2010 159 ti 1750 TBI sedan (red).
2004 GT 3.2 V6 (Stromboli Grey).
2008 159 TI Sportwagon 2.4 JTDM (Stromboli Grey).
1987 75 3 litre (red). My first 75 and now my son's.
2000 156 2 litre Twin Spark, ( Cosmos Blu metallic), my daughter's car.
2000 156 Monza Twin Spark, (Cosmos Blue metallic), sonís girlfiendís car.
1999 GTV 3 litre 24 valve V6, metallic black, (sonís new car).

Non Alfa
1988 Range Rover Classic Highline 3.9 V8

Past Alfas
1989 75 3 litre, written off by runaway van.
1990 75 3 litre Potenziata (black), now sold & living in Newcastle NSW.
1990 75 3 litre Potenziata (grey, sadly deceased due to fire).
1982 GTV 2 litre, red, (daughter's first Alfa)
2 x 1992 164s, (1 red, 1 grey).
2 x 1988 33s, (both red).
1985 GTV 2 litre, (white).
oz3litre is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 09-07-2016, 10:37 AM
Administrator
Administrator
 
AlfaBBAdmin's Avatar
 
Join Date: Apr 2012
Posts: 895
Garage
Quote:
Originally Posted by oz3litre View Post
Can you guys please put some effort into solving the problem of iPhone photos appearing upside down when trying to attach them? I have asked this before and nothing has been done. I find it unacceptable and am losing patience. It makes no difference with the orientation of the camera and rotating the pics before posting is ineffective. I am not interested in tricky workarounds and believe it is a software issue with the website and can be fixed if you put the right people on the job. Please do so.
Hi there, I'm sorry this has frustrated you but the truth is, no forum software exists that reads the EXIF data of a photo taken from a mobile. None of the major forum developers have cracked it. This is why people often come back with "edit the photo orientation" because that's the only consistent means to correct it short of uploading it on a file host server and even then. It is not a glitch, or error to be fixed, it's something that hasn't been developed yet for the mass market.

Kyle
AlfaBBAdmin is offline  
post #3 of 18 (permalink) Old 09-07-2016, 10:48 AM
Registered User
 
tubut's Avatar
 
Join Date: Sep 2003
Location: Vancouver, BC
Posts: 9,205
Garage
Agreed on the EXIF data (and Apple's screw up). However, leaning on the software supplier (vBulletin?) for adding "picture preview" and "rotate picture" functions should not be hard to do.

-Ruedi
[SIZE="1"]'63 2600 Touring Spider (AR 191437, the car that started the 2000/2600 International Register, reassembly in progress)
ex-'65 2600 SZ (AR 856043, the car in my avatar, sold as resto project to Austria)
Maintainer of a private 2600 SZ register (not the one in the Netherlands).[/SIZE]
tubut is online now  
Sponsored Links
Advertisement
 
post #4 of 18 (permalink) Old 09-07-2016, 11:01 AM
Registered User
 
Spitfire's Avatar
 
Join Date: Sep 2013
Location: Southern CT
Posts: 1,773
If I ever so slightly crop my iPhone pics before posting, they always come in with the correct orientation.

John
1991 Alfa Romeo 164L, 1993 Ford 5.0L Mustang
Spitfire is offline  
post #5 of 18 (permalink) Old 09-07-2016, 11:11 AM Thread Starter
Registered User
 
oz3litre's Avatar
 
Join Date: Jul 2005
Location: Adelaide South Australia
Posts: 3,806
Quote:
Originally Posted by tubut View Post
Agreed on the EXIF data (and Apple's screw up). However, leaning on the software supplier (vBulletin?) for adding "picture preview" and "rotate picture" functions should not be hard to do.
How about you try this suggestion of tubut's then guys?

Current Alfas
2010 159 ti 1750 TBI sedan (red).
2004 GT 3.2 V6 (Stromboli Grey).
2008 159 TI Sportwagon 2.4 JTDM (Stromboli Grey).
1987 75 3 litre (red). My first 75 and now my son's.
2000 156 2 litre Twin Spark, ( Cosmos Blu metallic), my daughter's car.
2000 156 Monza Twin Spark, (Cosmos Blue metallic), sonís girlfiendís car.
1999 GTV 3 litre 24 valve V6, metallic black, (sonís new car).

Non Alfa
1988 Range Rover Classic Highline 3.9 V8

Past Alfas
1989 75 3 litre, written off by runaway van.
1990 75 3 litre Potenziata (black), now sold & living in Newcastle NSW.
1990 75 3 litre Potenziata (grey, sadly deceased due to fire).
1982 GTV 2 litre, red, (daughter's first Alfa)
2 x 1992 164s, (1 red, 1 grey).
2 x 1988 33s, (both red).
1985 GTV 2 litre, (white).
oz3litre is offline  
post #6 of 18 (permalink) Old 09-07-2016, 11:12 AM Thread Starter
Registered User
 
oz3litre's Avatar
 
Join Date: Jul 2005
Location: Adelaide South Australia
Posts: 3,806
Quote:
Originally Posted by Spitfire View Post
If I ever so slightly crop my iPhone pics before posting, they always come in with the correct orientation.
Thanks, I will try that next time.

Current Alfas
2010 159 ti 1750 TBI sedan (red).
2004 GT 3.2 V6 (Stromboli Grey).
2008 159 TI Sportwagon 2.4 JTDM (Stromboli Grey).
1987 75 3 litre (red). My first 75 and now my son's.
2000 156 2 litre Twin Spark, ( Cosmos Blu metallic), my daughter's car.
2000 156 Monza Twin Spark, (Cosmos Blue metallic), sonís girlfiendís car.
1999 GTV 3 litre 24 valve V6, metallic black, (sonís new car).

Non Alfa
1988 Range Rover Classic Highline 3.9 V8

Past Alfas
1989 75 3 litre, written off by runaway van.
1990 75 3 litre Potenziata (black), now sold & living in Newcastle NSW.
1990 75 3 litre Potenziata (grey, sadly deceased due to fire).
1982 GTV 2 litre, red, (daughter's first Alfa)
2 x 1992 164s, (1 red, 1 grey).
2 x 1988 33s, (both red).
1985 GTV 2 litre, (white).
oz3litre is offline  
post #7 of 18 (permalink) Old 09-07-2016, 11:16 AM Thread Starter
Registered User
 
oz3litre's Avatar
 
Join Date: Jul 2005
Location: Adelaide South Australia
Posts: 3,806
Quote:
Originally Posted by AlfaBBAdmin View Post
Hi there, I'm sorry this has frustrated you but the truth is, no forum software exists that reads the EXIF data of a photo taken from a mobile. None of the major forum developers have cracked it. This is why people often come back with "edit the photo orientation" because that's the only consistent means to correct it short of uploading it on a file host server and even then. It is not a glitch, or error to be fixed, it's something that hasn't been developed yet for the mass market.

Kyle
As I said, I have tried rotating the pics in Apple "Photos" before attaching them and it makes no difference.

Current Alfas
2010 159 ti 1750 TBI sedan (red).
2004 GT 3.2 V6 (Stromboli Grey).
2008 159 TI Sportwagon 2.4 JTDM (Stromboli Grey).
1987 75 3 litre (red). My first 75 and now my son's.
2000 156 2 litre Twin Spark, ( Cosmos Blu metallic), my daughter's car.
2000 156 Monza Twin Spark, (Cosmos Blue metallic), sonís girlfiendís car.
1999 GTV 3 litre 24 valve V6, metallic black, (sonís new car).

Non Alfa
1988 Range Rover Classic Highline 3.9 V8

Past Alfas
1989 75 3 litre, written off by runaway van.
1990 75 3 litre Potenziata (black), now sold & living in Newcastle NSW.
1990 75 3 litre Potenziata (grey, sadly deceased due to fire).
1982 GTV 2 litre, red, (daughter's first Alfa)
2 x 1992 164s, (1 red, 1 grey).
2 x 1988 33s, (both red).
1985 GTV 2 litre, (white).
oz3litre is offline  
post #8 of 18 (permalink) Old 09-08-2016, 11:41 AM
Administrator
Administrator
 
AG Jeff's Avatar
 
Join Date: Jan 2015
Location: Chicago
Posts: 171
Garage
Might help but I have had the same problem.

Why Your iPhone Photos Are Upside Down & How To Fix That

Jeff M

Jeff
Community Manager/Admin
AutoGuide.com

If you need Admin support post here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
AG Jeff is offline  
post #9 of 18 (permalink) Old 09-08-2016, 03:52 PM
Registered User
 
Vivace's Avatar
 
Join Date: Jun 2005
Location: PNW
Posts: 1,987
Garage
Quote:
Originally Posted by oz3litre View Post
....photos appearing upside down when trying to attach them?...... It makes no difference with the orientation of the camera .
...waaait a minute..........aren't you from... Australia....?
brownie93 and Alfaboutvegas like this.

1967 1600 Spider
Vivace is offline  
post #10 of 18 (permalink) Old 09-08-2016, 04:42 PM
Registered User
 
Spitfire's Avatar
 
Join Date: Sep 2013
Location: Southern CT
Posts: 1,773
Quote:
Originally Posted by Vivace View Post
...waaait a minute..........aren't you from... Australia....?
I knew it was coming!

John
1991 Alfa Romeo 164L, 1993 Ford 5.0L Mustang
Spitfire is offline  
post #11 of 18 (permalink) Old 09-08-2016, 05:19 PM
Registered User
 
Spitfire's Avatar
 
Join Date: Sep 2013
Location: Southern CT
Posts: 1,773
Test pic. Phone sideways with volume buttons down.
Attached Images
 
AG Jeff likes this.

John
1991 Alfa Romeo 164L, 1993 Ford 5.0L Mustang
Spitfire is offline  
post #12 of 18 (permalink) Old 09-08-2016, 05:20 PM
Registered User
 
Spitfire's Avatar
 
Join Date: Sep 2013
Location: Southern CT
Posts: 1,773
Making a liar out of me. I didn't crop that and it came in fine.

John
1991 Alfa Romeo 164L, 1993 Ford 5.0L Mustang
Spitfire is offline  
post #13 of 18 (permalink) Old 09-08-2016, 05:56 PM
Registered User
 
Spitfire's Avatar
 
Join Date: Sep 2013
Location: Southern CT
Posts: 1,773
Test pic 2. Phone upright. Pic not cropped.
Attached Images
 

John
1991 Alfa Romeo 164L, 1993 Ford 5.0L Mustang
Spitfire is offline  
post #14 of 18 (permalink) Old 09-08-2016, 06:01 PM
Registered User
 
Spitfire's Avatar
 
Join Date: Sep 2013
Location: Southern CT
Posts: 1,773
Same pic cropped. Fixes the rotation problem.
Attached Images
 

John
1991 Alfa Romeo 164L, 1993 Ford 5.0L Mustang
Spitfire is offline  
post #15 of 18 (permalink) Old 09-08-2016, 08:00 PM Thread Starter
Registered User
 
oz3litre's Avatar
 
Join Date: Jul 2005
Location: Adelaide South Australia
Posts: 3,806
Interesting. What app did you use to crop the pic?

Current Alfas
2010 159 ti 1750 TBI sedan (red).
2004 GT 3.2 V6 (Stromboli Grey).
2008 159 TI Sportwagon 2.4 JTDM (Stromboli Grey).
1987 75 3 litre (red). My first 75 and now my son's.
2000 156 2 litre Twin Spark, ( Cosmos Blu metallic), my daughter's car.
2000 156 Monza Twin Spark, (Cosmos Blue metallic), sonís girlfiendís car.
1999 GTV 3 litre 24 valve V6, metallic black, (sonís new car).

Non Alfa
1988 Range Rover Classic Highline 3.9 V8

Past Alfas
1989 75 3 litre, written off by runaway van.
1990 75 3 litre Potenziata (black), now sold & living in Newcastle NSW.
1990 75 3 litre Potenziata (grey, sadly deceased due to fire).
1982 GTV 2 litre, red, (daughter's first Alfa)
2 x 1992 164s, (1 red, 1 grey).
2 x 1988 33s, (both red).
1985 GTV 2 litre, (white).
oz3litre is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome