Alfa Romeo Bulletin Board & Forums

Alfa Romeo Bulletin Board & Forums (https://www.alfabb.com/bb/forums/)
-   AROSC - Alfa Romeo Owners Club Southern California (https://www.alfabb.com/bb/forums/arosc-alfa-romeo-owners-club-southern-california/)
-   -   Got my Spider yesterday and may have broken it already! (https://www.alfabb.com/bb/forums/arosc-alfa-romeo-owners-club-southern-california/374849-got-my-spider-yesterday-may-have-broken-already.html)

dotcentral 12-06-2014 03:46 PM

Got my Spider yesterday and may have broken it already!
 
I was driving around town, and getting familiar with my car and enjoying a nice sunny day. Missed seeing a pothole and heard/felt a large bang. Was doing about 25 mph at the time. I pulled over and looked under the front, then at the pothole. Two large scrapes on the asphalt where the skid plate hit. No oil dripping out that I could see. I drove home, paying more attention to the pavement, and was a bit less rev happy as well. I may be paranoid after what happened, as while the engine seemed to run fine, it sound a little odd if I let the revs get a little high.

Parked the car and about an hour later looked under again. Metal cage/skid plate looks to be up against the bottom of the engine oil pan. Seemed to be two small drips, looking to come from the front corners of the pan.

Bottom of the engine was filthy on the car when I bought it, PO kept a large drip tray under the car. So there was some leakage going on prior, but that is pretty common on older cars in my experience.

How do I tell if this is a normal gasket issue that I can just keep an eye on the oil level or something more serious? Prefer not to pull the engine if I can avoid it. Guess I could clean it off and see where the leaks come from. What is the chance I did some internal engine damage?

Gubi 12-06-2014 03:52 PM

You're probably fine if it's running okay. The odd running noise is probably just the vibration from the pan being against the guard. This sort of thing happens all the time with a Spider and rough roads.

I would start by pulling off the guard and banging it back into shape: just whale on it a while with a hand sledgehammer. While you have it off, get some Gunk Heavy Duty engine cleaner and go to town on the engine and oil sump. If you get it all clean you should be able to tell how bad the leaks are and where they are.

dotcentral 12-07-2014 11:45 AM

Thanks for the input. Looked again this morning, just a couple tiny spots on the garage floor, so probably not much or any real damage caused. Good point about getting that guard bent back into shape, if for no other reason so if there is another big impact, the force doesn't get transmitted directly into the oil pan.

AlfaTango1 12-07-2014 11:51 AM

Lucky you had a pan guard :)

dotcentral 12-07-2014 11:55 AM

Quote:

Originally Posted by AlfaTango1 (Post 5918801)
Lucky you had a pan guard :)

Definitely.

tirefriar 12-07-2014 12:02 PM

Like Tom said, degrease the engine to get a good look at the oil pan. Hairline cracks are virtually impossible to see when smeared in gunk. It's those few drops that would be a cause of concern for me - definitely try to trace them for piece of mind if not for anything else....

skytop 12-17-2014 06:23 PM

Back in 1975, I bought a brand new Spider at a Alfa dealer in Westchester, NY. A few days later, I was pulling into a gas station and what appeared to be a 'normal' curb cut apron was too steep an incline for the low slung Spider. WHAM! I heard a bang and then some kind of vibration. The optional oil pan cage had been impacted and became bent. It was up against the oil pan. Similar probable to what you have. No damage to engine at all but the cage had to be removed and straightened (by the dealer, NOT ME!)
Any time you drive the little Spider, you most always being scanning for any bumps, humps, holes or inclines that might inflict unpleasantness upon you and your prized Spider.

dotcentral 12-17-2014 07:13 PM

Tried to beat the guard back in place this past weekend, but didn't make a lot of progress. Been really busy with work and the holidays. I am going to try and take it to a Alfa place in January to get that and maybe the power window fixed (unless I figure it out in the mean time). will have to go to the LA area, two foreign car shops here, but neither one wants to look at it.

Thanks all for your replies.

Gubi 12-17-2014 07:18 PM

Get a bigger hammer :D

Seriously: get a big ol' hand sledge, put the guard on some packed earth, and whale away. It'll bend back into shape, I promise.

dotcentral 12-17-2014 07:26 PM

Nope, I broke it beating on it. I would like someone that knows what shape this cage should really have and get it back into shape and weld the broken section back.

The cage has been banged and hit a few times before me of course. I took the cage loose in the front and was smacking it from the rear mount. One front nut was metric, the other standard fractional inch type nut. A few other improvised things going on as well. A few solid wacks, and it was moving, then suddenly it basically dropped s lot straight down as I probably hit a weak spot and it broke on me.


All times are GMT -7. The time now is 01:50 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2002-2011 AlfaBB.com All Rights Reserved.

 
For the best viewing experience please update your browser to Google Chrome