Alfetta GT Heater Control Light - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-21-2018, 09:32 PM Thread Starter
Registered User
 
ncng's Avatar
 
Join Date: Apr 2009
Location: Grass Valley, CA
Posts: 603
Alfetta GT Heater Control Light

I am a dufas, I have been renewing my fuses and light bulbs tonight from stuff I just got in
from Centerline. Even though it was working, I renewed my heater control bulb ( I have no AC),
heater controls were lighted before, but now I cannot figure out where to put it back to light my heater
controls as before? See attached photo taken in the dark, this area is usually lighted. Not since
I f'ed it up, thanks for your help, Happy Thanksgiving,
ncng
Attached Images
 
ncng is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-22-2018, 03:03 PM Thread Starter
Registered User
 
ncng's Avatar
 
Join Date: Apr 2009
Location: Grass Valley, CA
Posts: 603
Fixed it, I was trying find a place for the "Fasten Your Seat Belt" light to light my heater controls, found the standard side switch bulbs, however created a crazy new issue, heater fan was working with two speeds, now it works at full speed no matter what position the switch is in, I must have two wire touching? ncng
ncng is offline  
post #3 of 4 (permalink) Old 11-28-2018, 06:28 AM
Registered User
 
iachella's Avatar
 
Join Date: Sep 2005
Location: Concord, CA
Posts: 2,167
Quote:
now it works at full speed no matter what position the switch is in
Mine has been that way for years. It coincides with work I did to the area. I just assumed the switch went bad. Let me know if you figure that out.

Stefano
Concord, CA
iachella [at] gmail [dot] com
iachella is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 11-28-2018, 06:51 PM Thread Starter
Registered User
 
ncng's Avatar
 
Join Date: Apr 2009
Location: Grass Valley, CA
Posts: 603
You have to pull out "carefully" the fan switch, it comes straight out. on the side of the switch are two rectangular sleeves that hold the 1.2v lights,
with both bulbs working it will light the clear panel pretty well. I got replacement bulbs from Centerline - see link below

https://centerlinealfa.com/catalog/instrument-bulb-18mm

Quote:
Originally Posted by iachella View Post
Mine has been that way for years. It coincides with work I did to the area. I just assumed the switch went bad. Let me know if you figure that out.
ncng is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome