Alfa Romeo Bulletin Board & Forums - View Single Post - I cannot understand why every second car is not an Alfa Romeo
View Single Post
post #282 of (permalink) Old 09-03-2019, 04:12 PM Thread Starter
PSk
Registered User
 
Join Date: May 2003
Location: Tauranga New Zealand
Posts: 11,569
Send a message via AIM to PSk Send a message via Yahoo to PSk
Quote:
Originally Posted by alfettaparts2 View Post
Pete have you checked the rear lateral arm bushes. They also wear. Jack the rear and try moving the wheel at 9 and three. There should be no play.
I did not feel any play when I recently rotated the tyres, but will double check
Quote:
Front arms wear quickly and are checked every service.
Yes, and I do have play on left front, and suspect that this is where my "little" problem is, i.e. the front top inner bushes are worn, causing extra negative camber on the front resulting in increased inner tyre wear. On top of that I've reduced their pressures to 32 psi, which appears to have been a mistake. The tyres that are now needing replacement have just come off the front, but they are also older than the other pair
Quote:
A good wheel alignment operator can set your car up to your needs. Factory specs are not ideal.
I'm happy to have a little play here and "tone her down" a bit
Pete

'71 1750 Series 2 GTV:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
156 Series 1 v6 ... and remember it's all just opinions
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
PSk is offline  
 
 
For the best viewing experience please update your browser to Google Chrome