Alfa Romeo Bulletin Board & Forums - View Single Post - 1984 Maratona "Ran when parked..."
View Single Post
post #363 of (permalink) Old 05-02-2018, 09:44 PM Thread Starter
horsewidower
Senior Member
Gold Subscriber
 
horsewidower's Avatar
 
Join Date: Jun 2006
Location: Wilton Ca
Posts: 2,279
Well that was a productive couple of hours.

I found an old post from Toonrboy that was quite helpful. It was the sequence to follow if you are pulling the torsion bars from the front. Worked like a charm.



Setup the parts receiving area.


On to the task





Sent from my iPhone using Tapatalk

Everyday is a school day. Learning something new all the time

View my '74 GTV restoration at:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


View my '91 164s adventure at:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


But wait there's more: View my 164LS thread:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


You're kidding, another one?! 1984 GTV6 Maratona
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


You didn't...oh yes I did. '73 Berlina graduate course in rust repair. No thread yet, don't want to piss off the GTV

You didn't...oh yes I did II. 1995 164LS 5 speed, awesome when it runs!!!

Musings on shop related items:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
horsewidower is online now  
 
 
For the best viewing experience please update your browser to Google Chrome