Alfa Romeo Bulletin Board & Forums

Alfa Romeo Bulletin Board & Forums (https://www.alfabb.com/bb/forums/)
-   164 & 168 (1991-1995) (https://www.alfabb.com/bb/forums/164-168-1991-1995/)
-   -   Changing the Voltage Regulator in Alternator (https://www.alfabb.com/bb/forums/164-168-1991-1995/54772-changing-voltage-regulator-alternator.html)

Alfisto Steve 02-10-2008 04:32 AM

Changing the Voltage Regulator in Alternator
 
3 Attachment(s)
We are repairing GTV682 Bill's 164 with bent valves this weekend and while car apart we are doing some side repairs in engine bay such as installing a rebuilt starter, rebuilt cooling fan motor, new low speed cooling fan resistor, new a/c heater blower motor and a new voltage regulator in alternator.

We would have replaced bearing in a/c clutch pulley too but car has new compressor assembly already installed. Lucky us as that was one less item to ZERO time.

Here is picture of old and new voltage regulator for alternator. As you can see brushes worn quite a bit. We had to change broken radio noise suppressor, too.

gtv682 02-10-2008 04:37 PM

what a difference
 
Wow! What a difference.

BlackAlfa 02-17-2008 08:23 PM

24V voltage regulator
 
1 Attachment(s)
24V alternator and voltage regulator are slightly different from the pictures that Steve posted. The 24V alternator has a plastic cover at the back of the alternator and it has to be removed to get to the voltage regulator. But in order to take the plastic cover off, the front exhaust manifold heat shield need to be removed first. In the first picture, you can see the heat shield was drop down and the alternator back plastic cover was move to the side. The A/C hoses are somewhat in the way. The second pic shows the voltage regulator as mounted on the back of the alternator. The lower two pics show the voltage regulator.

Why I pulled the voltage regulator? The car was showing inadequate electrical power supply symptoms (even with a new battery) - voltage dropped too much whenever I switched on some additional loads. I pulled the voltage regulator today and cleaned all the electrical contacts that I came across. I put the old voltage regulator back (don't have a new one on hand) and some preliminary measurements show that the charging system is working much better now. It was charging at ~14.6V with engine idling and it still stayed at ~14V with most electrical accessories turned on (before cleaning, it dropped below 12V)!

kuseetha 07-04-2019 03:28 AM

3 Attachment(s)
Quote:

Originally Posted by BlackAlfa (Post 489635)
24V alternator and voltage regulator are slightly different from the pictures that Steve posted. The 24V alternator has a plastic cover at the back of the alternator and it has to be removed to get to the voltage regulator. But in order to take the plastic cover off, the front exhaust manifold heat shield need to be removed first. In the first picture, you can see the heat shield was drop down and the alternator back plastic cover was move to the side. The A/C hoses are somewhat in the way. The second pic shows the voltage regulator as mounted on the back of the alternator. The lower two pics show the voltage regulator.

Why I pulled the voltage regulator? The car was showing inadequate electrical power supply symptoms (even with a new battery) - voltage dropped too much whenever I switched on some additional loads. I pulled the voltage regulator today and cleaned all the electrical contacts that I came across. I put the old voltage regulator back (don't have a new one on hand) and some preliminary measurements show that the charging system is working much better now. It was charging at ~14.6V with engine idling and it still stayed at ~14V with most electrical accessories turned on (before cleaning, it dropped below 12V)!


Thank you so much. :flowers: I had this problem of overheating when the A/C was ON. I found out it happens because alternator output is low when electrical load is high (goes to low 12s in Voltage), then the radiator fan spins slower than required. So the temp rises.

I anticipated a total removal of the alternator and replace its internal regulator. But thanks to you, I managed to scrub clean the 3 contacts and push them a little bit forward with pliers so they contact well. Now with headlights ON, AC ON and blower fan at full speed and radiator fan at high speed, it still stays above 12.9V.

I have to replace this part but for now, this is manageable. Thank you once again. :clap:

richardbradford 07-21-2019 01:26 PM

1 Attachment(s)
Hi,

Have alternator off, 164 24v, and my repair kit includes a lot more than just the regulator. For example, do I need to open it up further to add the supplied extra two pairs of bushes somewhere? If so, how is the best way of doing it?
Thanks.

kuseetha 07-21-2019 08:07 PM

I have overhauled about 3 alternators and they all had only 2 brushes. So 164 alternator can't be so unusual. I think those extra brushes would go in to the regulator once it's brushes wear off.
You might have to de-solder and remove the worn out brushes and re-solder the new ones in.

Sent from my SM-J730F using Tapatalk

richardbradford 07-23-2019 09:49 AM

Quote:

Originally Posted by kuseetha (Post 8442214)
I have overhauled about 3 alternators and they all had only 2 brushes. So 164 alternator can't be so unusual. I think those extra brushes would go in to the regulator once it's brushes wear off.
You might have to de-solder and remove the worn out brushes and re-solder the new ones in.

Sent from my SM-J730F using Tapatalk

That makes sense. Thanks.


All times are GMT -7. The time now is 07:30 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2002-2011 AlfaBB.com All Rights Reserved.

 
For the best viewing experience please update your browser to Google Chrome