Alfa Romeo Bulletin Board & Forums - View Single Post - New Alfa 164 owner says hi, and has questions!
View Single Post
post #4 of (permalink) Old 07-16-2012, 11:24 AM
Alfisto Steve
Senior Member
Platinum Subscriber
 
Alfisto Steve's Avatar
 
Join Date: Dec 2003
Location: VB, VA
Posts: 26,614
Garage
As for hard starting issue test low fuel pressure/fuel flow and no trapped fuel pressure after engine shut off.

http://www.alfabb.com/bb/forums/390221-post2.html

http://www.alfabb.com/bb/forums/164-...pumps-etc.html

Lots of other posts out there on fuel pump issues, testing and replacing fuel line in tank with sumersible hose.

As for running hot verify cooling fan runs on both low and high speed circuits correctly. 42 psi and 8 oz flow in 15 seconds.

Lots of stuff book,arked here: http://www.alfabb.com/bb/forums/164-...ance-tips.html

Also verify condtion of spring loaded carbon button inside center of dizzy cap and condition and resistance reading of rotor in it , too. 1.1kohms.

Verify resistance of coil wire (1 kohms and interior of cap and coil tower for cleanliness.

Ciao, Alfisto Steve
Virginia Beach, VA
AROC 164 Tech Advisor

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

My Maintenance Sticky:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Alfa Semi-Daily driver: USA model - BB2 1991 164S Black Beauty II ALFISTO [U]

[U] BB1 1991 164L w/S engine and A/T now excess to inventory [U]

Daily driver and parts hauler but not car hauler 2004 Jeep Grand Cherokee Overland 4.7L H.O. V-8

"A day without an Alfa whine is like a day without sunshine"

Last edited by Alfisto Steve; 07-16-2012 at 11:41 AM.
Alfisto Steve is offline  
 
 
For the best viewing experience please update your browser to Google Chrome