1969 Spider tandem brake system - Alfa Romeo Bulletin Board & Forums

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-06-2017, 11:37 AM Thread Starter
Junior Member
Platinum Subscriber
 
Join Date: Apr 2016
Location: Clarkston, WA
Posts: 26
1969 Spider tandem brake system

Hopefully someone can help solve my brake problem. I recently installed the brake master cylinder which I had rebuilt. When I apply the brakes, the front brakes lock up and do not release. I appears to me that the master brake cylinder piston for the front brakes (rear chamber) is not moving enough to to allow the pressure to be released. Has anyone had this problem? Am I missing something obvious? I really don't want to remove the MC and send it away again unless necessary. Thanks
Stoney is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome