Coil wiring question - Alfa Romeo Bulletin Board & Forums

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-15-2017, 06:39 PM Thread Starter
Senior Member
Gold Subscriber
 
Join Date: Apr 2006
Location: Blacksburg, VA
Posts: 181
Coil wiring question

'74 Spider. Please take a look at the pics and tell me your thoughts on the wiring. Car idles at around 4000 rpm. I'm wondering if the coil wiring is causing the problem.

Thanks,

Joe G
74 Spider.
Attached Images
  
Alfa1277 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-15-2017, 08:29 PM
Registered User
 
Alfajay's Avatar
 
Join Date: Jan 2005
Location: San Juan Capistrano
Posts: 7,775
I can't make heads nor tails of your wiring from those photos, but it's hard to imagine how incorrect coil wiring would allow your engine to run OK, but with an incorrect idle speed.

What leads you to suspect the coil wiring? Is the car still Spica? When did you last lubricate your advance weights?

Jay Mackro
San Juan Capistrano, CA

'63 Guilia spider
'65 Guilia Sprint GT
'67 Duetto
'91 164L

Last edited by Alfajay; 03-15-2017 at 08:33 PM.
Alfajay is offline  
post #3 of 5 (permalink) Old 03-15-2017, 08:46 PM
I'm with Jay, I can't see what's going on. But the coil would not determine idle. Did you check the timing? Did you check the throttle cable?
gprocket is online now  
 
post #4 of 5 (permalink) Old 03-16-2017, 04:57 AM Thread Starter
Senior Member
Gold Subscriber
 
Join Date: Apr 2006
Location: Blacksburg, VA
Posts: 181
Quote:
Originally Posted by gprocket View Post
I'm with Jay, I can't see what's going on. But the coil would not determine idle. Did you check the timing? Did you check the throttle cable?
Thanks for replies. I'm a novice, so I apologize for my ignorance. I checked timing, throttle and am at a loss for what's going on. Car was switched to carbs - they seem to check out ok. The wiring to the coil looked to be different than the wiring diagram, so I thought I would ask. I removed the carbs and am taking to a shop to make sure there's no issues with them. I removed the throttle cable and still had the high idle.
Alfa1277 is offline  
post #5 of 5 (permalink) Old 03-16-2017, 07:39 AM
Registered User
 
Alfajay's Avatar
 
Join Date: Jan 2005
Location: San Juan Capistrano
Posts: 7,775
Quote:
Originally Posted by Alfa1277 View Post
Car was switched to carbs - they seem to check out ok. .... I removed the carbs and am taking to a shop to make sure there's no issues with them.
OK, I think we are homing in on the answer here.

My guess is that your carbs are fine, but they are not properly adjusted. So taking them off and showing them to a pro won't tell you anything. A better idea is to take the whole car to someone who knows how to synchronize and tune Weber carbs.

What exactly do you mean by "check out ok"? That the car runs well at speed? Webers will tolerate a lot of mis-adjustment, and still perform OK at highway speeds. It's getting them to idle that requires more precise tuning.

Who did the carburetor conversion?

Jay Mackro
San Juan Capistrano, CA

'63 Guilia spider
'65 Guilia Sprint GT
'67 Duetto
'91 164L

Last edited by Alfajay; 03-16-2017 at 07:42 AM.
Alfajay is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome