Request Activation Codes - Alfa Romeo Bulletin Board & Forums

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-26-2008, 11:52 PM Thread Starter
Admin
Administrator
 
smestas's Avatar
 
Join Date: Nov 2002
Location: Santa Clarita, CA
Posts: 4,862
Request Activation Codes

Registration is a two step process.

Part one is completing the registration form.

Part two is replying to a confirmation email that is sent out after a few minutes of completing step 1. If you have not received this confirmation email you can re-request the codes via this activation code link.

IMPORTANT! Please also make sure that our email notifications sent via the site are not getting caught in any SPAM software that you might have running or getting caught in any SPAM folders. If you do have software blocking such emails you can add "support@alfabb.com" to your allowed list of mail recipients.


.

Simon Mestas
smestas is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome