Alfa Spider power top problem - Alfa Romeo Bulletin Board & Forums

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-31-2016, 09:52 PM Thread Starter
Registered User
 
Join Date: Jul 2015
Posts: 6
Alfa Spider power top problem

Hey all,

Once the car is turned on, every few seconds the winder motor for the power top engages (with an audible clunk). Since the top is up and not being retracted, this does nothing and after about a second the motor disengages. It repeats this process continually.

Probably related to this, the top no longer functions -- the hood under which the top is stored when retracted will not open, undoubtedly because the winder motor is not detensioning the cables.

I'm capable of removing the motor (I've done it before), but I'm curious what could be causing this periodic motor firing. I've checked the obvious things (like making sure the switch on the side isn't being pressed by the seat).

Thoughts?
topdown is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-02-2016, 08:44 AM
Registered User
 
Join Date: Oct 2006
Location: Denmark
Posts: 1,527
Send a message via AIM to Erik
I have recently on the Danish Alfa Club's web read about a top problem - mostly due to some leak in the hydraulic system
Perhaps with translategoogle.com you can get ideas of your issue.
Alfa Romeo Klub Danmark - Hydraulikolie og -cylinder kaleche
Erik is offline  
post #3 of 5 (permalink) Old 08-02-2016, 02:04 PM Thread Starter
Registered User
 
Join Date: Jul 2015
Posts: 6
Hey Erik!

Thanks for the reply! The problem in this case is with the electric motor, not the hydraulic rams (I've heard other people talking about hydraulic problems, but in my experience that part of the system is pretty reliable).

This morning I unplugged the motor and gave it a few whangs with the back end of my screwdriver. That seemed to fix it. Still no idea what caused the malfunction in the first place, but some good old orangutan engineering fixed it right up.

(For the record, smacking vital components with blunt objects isn't my USUAL method of problem solving, but in the case of this motor it seems that sometimes the plastic gears can get stuck or slip somehow and a good thwack will set them right).
topdown is offline  
 
post #4 of 5 (permalink) Old 08-02-2016, 03:22 PM
Registered User
 
Join Date: Oct 2006
Location: Denmark
Posts: 1,527
Send a message via AIM to Erik
(For the record, smacking vital components with blunt objects isn't my USUAL method of problem solving, but in the case of this motor it seems that sometimes the plastic gears can get stuck or slip somehow and a good thwack will set them right).
If it helps its all right !
Erik is offline  
post #5 of 5 (permalink) Old 08-04-2016, 10:26 PM
Registered User
 
kens's Avatar
 
Join Date: Nov 2002
Posts: 232
My nylon gear cracked, locking down the release. Replacement gears have been made, try an eBay search if yours is broken.

In addition, with a gear in good condition, all too often binding would happen so that the lid release would not operate. The motor and gear is designed so that pressing/squeezing the housing toward the back of the car, serves as an emergency release. I leave the cover off for easy access. Place hands on each side of the housing, a firm grip will release.
kens is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome