Milano No Spark - Alfa Romeo Bulletin Board & Forums

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-17-2017, 05:52 AM Thread Starter
Senior Member
Platinum Subscriber
 
MidLifeCrisis's Avatar
 
Join Date: Apr 2005
Location: Connecticut
Posts: 921
Milano No Spark

Hi,

My son and his college buddies are attempting to turn a rusty '87 Milano into a Lemons car... Great to see the Alfa bug getting passed down to younger generations. I've worked on spider L-Jet systems before and have read the great troubleshooting guides available on the BB, but the Milano system is obviously a little different from what I'm used to.

We have 12V to the coil but no spark. The tachometer sender that sits under the coil and that's connected to the ignition harness is conspicuously absent. Is this component needed in order to get spark? Is this the equivalent of the flywheel pickups on a spider L-Jet system?

Thanks,

Michael.
MidLifeCrisis is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-17-2017, 06:03 AM
Senior Member
Platinum Subscriber
 
Alfisto Steve's Avatar
 
Join Date: Dec 2003
Location: VB, VA
Posts: 24,468
Quote:
Originally Posted by MidLifeCrisis View Post
Hi,

My son and his college buddies are attempting to turn a rusty '87 Milano into a Lemons car... Great to see the Alfa bug getting passed down to younger generations. I've worked on spider L-Jet systems before and have read the great troubleshooting guides available on the BB, but the Milano system is obviously a little different from what I'm used to.

We have 12V to the coil but no spark. The tachometer sender that sits under the coil and that's connected to the ignition harness is conspicuously absent. Is this component needed in order to get spark? Is this the equivalent of the flywheel pickups on a spider L-Jet system?

Thanks,

Michael.

That is not a tach sender per se. It is ignition amplifier and yes it is needed.

See this link for some more info:

Defective Verde Coil History



Defective Verde Coil History

Ciao, Alfisto Steve
Virginia Beach, VA
AROC 164 Tech Advisor

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

My Maintenance Sticky:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Daily drivers: USA models - 1991 164S Black Beauty II ALFISTO;

Daughter's current ride: BB1 my 164L and Her Granddads 2002 Ford Taurus is back up.

New parts hauler but not car hauler 2004 Jeep Grand Cherokee Overland 4.7L H.O. V-8

Needing TLC non-blackbeast the 93 164L

"A day without an Alfa whine is like a day without sunshine"

Last edited by Alfisto Steve; 03-17-2017 at 06:18 AM.
Alfisto Steve is offline  
post #3 of 3 (permalink) Old 03-17-2017, 06:12 AM Thread Starter
Senior Member
Platinum Subscriber
 
MidLifeCrisis's Avatar
 
Join Date: Apr 2005
Location: Connecticut
Posts: 921
Thank you!
MidLifeCrisis is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome