Speedometer amplifier - Page 4 - Alfa Romeo Bulletin Board & Forums

Reply
 
LinkBack Thread Tools Display Modes
post #46 of 55 (permalink) Old 11-13-2015, 09:35 AM
Registered User
 
Alfetta GTV's Avatar
 
Join Date: Aug 2011
Location: Genova
Posts: 30
Looking the pictures, the SGI-5C has 4 little switches, the SGI-5E not....it could be a problem?

Thanks

Alfetta GTV 2.0 1982
Toyota Celica Turbo All Trac 1991
Alfetta GTV is offline  
Sponsored Links
Advertisement
 
post #47 of 55 (permalink) Old 11-13-2015, 09:41 AM Thread Starter
Senior Member
Platinum Subscriber
 
alfaparticle's Avatar
 
Join Date: Oct 2004
Location: Columbia SC
Posts: 9,742
The 5C that is sold by Summit Racing is the one that I used. There must be some other way of setting up the 5E but I have not used one.

Ed Prytherch
79 Spider
85 GTV6 3L
76 Suzuki GT500

A little government and a little luck are necessary in life, but only a fool trusts either of them. - P.J. O'Rourke
alfaparticle is online now  
post #48 of 55 (permalink) Old 11-13-2015, 09:44 AM
Registered User
 
Alfetta GTV's Avatar
 
Join Date: Aug 2011
Location: Genova
Posts: 30
Ok, thank you

Alfetta GTV 2.0 1982
Toyota Celica Turbo All Trac 1991
Alfetta GTV is offline  
 
post #49 of 55 (permalink) Old 11-14-2015, 03:59 AM
Registered User
 
kredden's Avatar
 
Join Date: Jul 2003
Location: Newcastle, WA
Posts: 3,226
I just looked at the instruction manual for the 5E (http://www.dakotadigital.com/pdf/650528a_SGI-5E.pdf) and it looks pretty much the same as the 5C except instead of the dip switches it has a little LED screen and the two buttons to change mode. I've got two 5C's and they work great, the 5E looks like it is just the next rev of this product.

Kevin

Currently Alfaless. Ex: 87 Verde, 86 GTV6, 67 Super, 86 Spider, 88 LeMons Verde
Milano registry custodian(
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
)
kredden is offline  
post #50 of 55 (permalink) Old 11-14-2015, 04:26 AM Thread Starter
Senior Member
Platinum Subscriber
 
alfaparticle's Avatar
 
Join Date: Oct 2004
Location: Columbia SC
Posts: 9,742
Quote:
I've got two 5C's and they work great
I bet you wish they were 4C's

Ed Prytherch
79 Spider
85 GTV6 3L
76 Suzuki GT500

A little government and a little luck are necessary in life, but only a fool trusts either of them. - P.J. O'Rourke
alfaparticle is online now  
post #51 of 55 (permalink) Old 11-14-2015, 05:38 AM
Registered User
 
kredden's Avatar
 
Join Date: Jul 2003
Location: Newcastle, WA
Posts: 3,226
Yeah, or even one 8C!

Kevin

Currently Alfaless. Ex: 87 Verde, 86 GTV6, 67 Super, 86 Spider, 88 LeMons Verde
Milano registry custodian(
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
)
kredden is offline  
post #52 of 55 (permalink) Old 11-16-2015, 06:26 AM
Registered User
 
Alfetta GTV's Avatar
 
Join Date: Aug 2011
Location: Genova
Posts: 30
Alfetta GTV is offline  
post #53 of 55 (permalink) Old 09-20-2016, 10:48 PM
Registered User
 
ryan.f's Avatar
 
Join Date: Jun 2006
Location: San Francisco Bay Area
Posts: 112
Hello, I'm curious if anyone got this to work with the SGI-5E?

Thanks,

-ryan
ryan.f is offline  
post #54 of 55 (permalink) Old 02-14-2017, 12:59 PM Thread Starter
Senior Member
Platinum Subscriber
 
alfaparticle's Avatar
 
Join Date: Oct 2004
Location: Columbia SC
Posts: 9,742
Bruce Sharer sent me a speedometer amplifier to test and it was not working. The problem was a blown output transistor and it is working fine now with a new one. All three of the amplifiers that I have repaired have had the same failure.

Ed Prytherch
79 Spider
85 GTV6 3L
76 Suzuki GT500

A little government and a little luck are necessary in life, but only a fool trusts either of them. - P.J. O'Rourke
alfaparticle is online now  
post #55 of 55 (permalink) Old 02-23-2017, 10:20 AM Thread Starter
Senior Member
Platinum Subscriber
 
alfaparticle's Avatar
 
Join Date: Oct 2004
Location: Columbia SC
Posts: 9,742
Dakota Digital SGI-5E

I set up the newer style Dakota Digital box today for Bruce Sharer. The wiring diagram is the same as the one in post #16 except that the pink wire should go to OUT 1 and a 10K resistor should be connected between IN and GND. The configuration should be LO-LO and the adjustment factor that is shown when you adjust it will be about .320.

Ed Prytherch
79 Spider
85 GTV6 3L
76 Suzuki GT500

A little government and a little luck are necessary in life, but only a fool trusts either of them. - P.J. O'Rourke
alfaparticle is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
Replace with
For the best viewing experience please update your browser to Google Chrome