clutch slave hose wont fit. help - Page 2 - Alfa Romeo Bulletin Board & Forums

Reply
 
LinkBack Thread Tools Display Modes
post #16 of 16 (permalink) Old 03-20-2017, 11:34 AM
Senior Member
Gold Subscriber
 
not2old4toys's Avatar
 
Join Date: Feb 2012
Location: Sisters, Oregon
Posts: 1,710
Any manufacture making a hose specific to a particular year and model Vintage vehicle is doomed. So they make one that will fit a variety of models and years. As long as the threads engage and the flare bottoms out, thread length is irrelevant.
not2old4toys is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome