Pertronix Ignitor on different Bosch distributor - Alfa Romeo Bulletin Board & Forums

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 11-16-2016, 01:30 PM Thread Starter
Registered User
 
Join Date: Feb 2007
Location: Trondheim, Norway
Posts: 169
Pertronix Ignitor on different Bosch distributor

I bought an Ignitor for my Bosch distributor a while back. When restoring the distributor, the Ignitor seemd to be for a different Bosch-unit, as the mounting holes were different. I managed to adapt the Ignitor to the distributor, adding a mounting hole for the unit. I have been having some trouble starting the engine since the complete engine rebuild. I am getting a spark, but I am wondering if it is possible to get a weaker spark if the ignitor is mounted a degree or two off?
thisquietplace is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 11-16-2016, 01:41 PM
Senior Member
Gold Subscriber
 
Jim G's Avatar
 
Join Date: Feb 2006
Location: Ga
Posts: 2,365
Garage
Its probably out of phase. You can send the whole dist. with the igniter to pertronix and they will adjust into get it in phase. If you don't want to send it. Call their tech line and ask for Carl. He can explain how to do it.

1969 1750 Spider Veloce w/dual webers, 1969 1750 Berlina, 1971 1750 Spider Veloce w/ dual webers, 1985 Spider Veloce 23,000 orig. miles, {Two} 1986 Spider Veloces, 1987 Spider Veloce bought new, 1988 Quadrifoglio, 1991 164S, Plus several more. I think they are breeding.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
I just got 2 more.
Jim G is offline  
post #3 of 7 (permalink) Old 11-16-2016, 02:20 PM Thread Starter
Registered User
 
Join Date: Feb 2007
Location: Trondheim, Norway
Posts: 169
Thank you, if I am going to put any more money into the distributor, I might as well just get a programmable unit, and sell the Ignitor. Will give Carl a call first.

Last edited by thisquietplace; 11-16-2016 at 02:26 PM.
thisquietplace is offline  
 
post #4 of 7 (permalink) Old 11-16-2016, 03:02 PM
Registered User
 
Alfajay's Avatar
 
Join Date: Jan 2005
Location: San Juan Capistrano
Posts: 7,978
Quote:
Originally Posted by Jim G View Post
Its probably out of phase.
What I think Jim is getting at is that your Ignitor may be placed incorrectly so that it is firing the coil when the rotor isn't aligned with one of the four studs on the distributor cap. That would force the spark to jump a long air gap inside the distributor cap to get to the wire and ultimately to the spark plug.

Most likely Pertronix tech support will just tell you to get the correct Ignitor for your distributor. But you might be able to drill some new mounting holes so that it fires when the rotor is in phase with the output stud. Or just buy a 1-2-3.

Jay Mackro
San Juan Capistrano, CA

'63 Guilia spider
'65 Guilia Sprint GT
'67 Duetto
'91 164L
Alfajay is offline  
post #5 of 7 (permalink) Old 11-16-2016, 04:08 PM
Senior Member
Gold Subscriber
 
Jim G's Avatar
 
Join Date: Feb 2006
Location: Ga
Posts: 2,365
Garage
The couple of ones that I had to send to Pertronix to have phased. They did it at no charge.

1969 1750 Spider Veloce w/dual webers, 1969 1750 Berlina, 1971 1750 Spider Veloce w/ dual webers, 1985 Spider Veloce 23,000 orig. miles, {Two} 1986 Spider Veloces, 1987 Spider Veloce bought new, 1988 Quadrifoglio, 1991 164S, Plus several more. I think they are breeding.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
I just got 2 more.
Jim G is offline  
post #6 of 7 (permalink) Old 11-16-2016, 04:33 PM Thread Starter
Registered User
 
Join Date: Feb 2007
Location: Trondheim, Norway
Posts: 169
Is it possible to measure the output to the spark plug and compare it to a desired output range, or would I just be blowing up my multimeter? The Bosch is from a 1300, and the engine is a 1750, so I might be better off getting a distributor with an adjustable advance curve either way
thisquietplace is offline  
post #7 of 7 (permalink) Old 11-16-2016, 08:40 PM
Senior Member
Gold Subscriber
 
Jim G's Avatar
 
Join Date: Feb 2006
Location: Ga
Posts: 2,365
Garage
Quote:
Originally Posted by thisquietplace View Post
Is it possible to measure the output to the spark plug and compare it to a desired output range, or would I just be blowing up my multimeter? The Bosch is from a 1300, and the engine is a 1750, so I might be better off getting a distributor with an adjustable advance curve either way
Phasing is what Alfajay described in his post. I think you can do it with a test light. In the past I've used an old Sun distributer testing machine. Either way you have to have a battery and several wires hooked up.

Call or email Pertronix. They can tell you how to check the phasing and should be able to give you a diagram on how to hook power up to the igniter and teat it.

1969 1750 Spider Veloce w/dual webers, 1969 1750 Berlina, 1971 1750 Spider Veloce w/ dual webers, 1985 Spider Veloce 23,000 orig. miles, {Two} 1986 Spider Veloces, 1987 Spider Veloce bought new, 1988 Quadrifoglio, 1991 164S, Plus several more. I think they are breeding.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
I just got 2 more.
Jim G is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome