fuel pump low voltage - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-08-2004, 12:53 PM Thread Starter
Registered User
 
alfamarty's Avatar
 
Join Date: Feb 2004
Location: Pacifica, Ca
Posts: 165
fuel pump low voltage

hi I am having a low voltage to the fuel pump- 86 gtv6 . when the cooling fans kick on I get only 10.5 volts when they are not on I get over 12v.when I operate the elec windows or heater fan I get a momentary loss of power (presumably because I'm not getting enough voltage to the fuel pump.other than that I get over 12v when its runiing or 14.5 v when it's charging. I've never used a forum before so excuse me if I'm doing this wrong thanls in advance
alfamarty is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-08-2004, 01:18 PM
Trained Professional
Platinum SubscriberAdministrator
 
papajam's Avatar
 
Join Date: Feb 2003
Location: New Jersey USA
Posts: 14,299
Welcome to the Board, alfamarty!
Sounds like you have two things going on. The charging system needs to put out 13.5v minimum all the time the engines running; not 'over 12'. And there's excessive voltage drop to the fuel pump. Perhaps a corroded connection somewhere? I'll have a look at the schematic. In the meantime, someone with more GTV6 experience than I will probably chime in.

Jim

Series 2 USA 1750 GTV (in Series 1 European clothing)
papajam is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome