Help 1986 graduate electrical night mare - Alfa Romeo Bulletin Board & Forums

  #1 (permalink)  
Old 04-25-2009, 11:53 AM
Registered User
Gold Subscriber
 
Join Date: Apr 2009
Posts: 21
Help 1986 graduate electrical night mare

can some one help me I just bought a 86 graduate with only 32000 on it and when i went to look at it the owner had lost the keys so he destrioed the ignition switch and had the car hot wired so i could see the the car was getting spark. Well we got the car home and replaced the switch the car turns over but now we do not get any power to the coil does the green wire coming off the switch go to any thing????? does any body have a wiring diagram for this car I have a 85 graduate but nothing is the same so it is no help to try and follow its wiring Help!!!
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-25-2009, 12:27 PM
ghnl's Avatar
Moderator
Platinum SubscriberModerator
 
Join Date: Oct 2005
Location: Mebane, NC
Posts: 12,037
Send a PM to BB member PapaJam (find one of his posts, click on his username and select 'send a PM'. In the PM ask for a wire diagram for your model Alfa. Include your email address & he'll reply with some .pdf files of the best wire diagrams for chasing electrical troubles in your car.

I took a copy of the files to an office supply store and had them print out 11" X 17" color copies and plastic laminate them.

Meanwhile, here a snip from the Alfa shop manual re: ignition switch connections.
Attached Images
 
__________________
- - Eric
don't read this
~ 1984 Spider Veloce ~
- -~ 1981 GTV-6 ~
Mebane, North Carolina

L-jetronic Spider diagnosis (1982-1989)
L-jetronic V-6 diagnosis
OK injectors - fuel injector cleaning
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-25-2009, 03:06 PM
Tifosi's Avatar
1966-2013
Platinum Subscriber
 
Join Date: Mar 2006
Location: Northern NY, USA
Posts: 13,741
Green wire:

I'm betting that you got the wrong replacement switch. There is a difference between pre-86 ignition switches and post-86 ignition switches, both in wiring harness and physical length. (the above diagram is for a post-86 switch IIRC, or at least it comes out of the book covering monopod cars, which is from 86~94)

An 86+ can be made to work on an 85- and vice versa, but there's some cobbling involved to accomplish it and the switch housing will be either too short (85 in an 86) or too long (86 in an 85) for the column clamshell cover.

Papajam is aware of what tweaks need to occur and should be able to assist in that department, though simply having the correct replacement ignition switch to begin with would have simplified things. (unless of course the wiring issue is a result of DPO rather than the wrong replacement part)
__________________
Darren
'84 manufacture ~ '85 MY Spider Graduate
Spider technical FAQ
ghnl's '82~'89/Series 3 Spider L~jet diagnostic page
as hosted by
Greg Gordon's HI Performance Store
& OK Injectors

Last edited by Tifosi; 04-25-2009 at 03:12 PM.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-18-2010, 02:59 PM
Registered User
 
Join Date: Sep 2010
Posts: 10
I have a 1986 spider VELOCE , this is day 3, total miles 87,000 it has been setting for 8 years. It ran fine from DC to Florida no big problems except , no turn signals, no dash lites and now it will not start, i changed the fuel filter, the fuel pump, But I can not get a signal at the fuel pump???? It started once after the fuel pump change, and I let it idle for 2 minutes, now it will not start, what do you suggest ?? I have no book or a electric diagram.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off










Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2002-2011 AlfaBB.com All Rights Reserved.



SEO by vBSEO 3.3.2