GTV6 Gas Tank Noise - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 12-06-2007, 03:53 AM Thread Starter
Registered User
 
jpc823's Avatar
 
Join Date: Dec 2005
Location: Long Island, NY
Posts: 95
GTV6 Gas Tank Noise

Recently the gas tank on my GTV6 has started to make a noise when I shut the engine off after driving the car. The sound is like a piece of metal that flexes back to it's orignal shape from a distorted shape. It's almost like there's a pressure buildup that finally releases after the car is turned off. Has anyone had a similar problem or any ideas on what's causing this???
Thanks

[B] [COLOR="Red"][U][B]Current Alfa's[/B][/U][/COLOR]
[B]1995 164LS[/B]
[B]1990 Spider Quad[/B]
[B]1986 GTV6[/B]
1971 GTV 1750[/B]
jpc823 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 12-06-2007, 09:32 AM
Registered User
 
Balocco211's Avatar
 
Join Date: May 2006
Location: AROO Territory
Posts: 577
After you shut off engine, what happens if you open the gas cap?
Balocco211 is offline  
post #3 of 11 (permalink) Old 12-06-2007, 09:41 AM Thread Starter
Registered User
 
jpc823's Avatar
 
Join Date: Dec 2005
Location: Long Island, NY
Posts: 95
I can hear the pressure releasing, but still get a bang from the gas tank.

[B] [COLOR="Red"][U][B]Current Alfa's[/B][/U][/COLOR]
[B]1995 164LS[/B]
[B]1990 Spider Quad[/B]
[B]1986 GTV6[/B]
1971 GTV 1750[/B]
jpc823 is offline  
post #4 of 11 (permalink) Old 12-06-2007, 09:43 AM Thread Starter
Registered User
 
jpc823's Avatar
 
Join Date: Dec 2005
Location: Long Island, NY
Posts: 95
I've also noticed that the bang I get from the tank is louder when there is less gas in the tank. With a full tank the sound is more muted.

[B] [COLOR="Red"][U][B]Current Alfa's[/B][/U][/COLOR]
[B]1995 164LS[/B]
[B]1990 Spider Quad[/B]
[B]1986 GTV6[/B]
1971 GTV 1750[/B]
jpc823 is offline  
post #5 of 11 (permalink) Old 12-06-2007, 09:57 AM
mjr
Registered User
 
Join Date: Jul 2007
Posts: 324
tank over pressurisation. empty tank, remove vent valves, and clean
mjr is offline  
post #6 of 11 (permalink) Old 12-06-2007, 10:14 AM Thread Starter
Registered User
 
jpc823's Avatar
 
Join Date: Dec 2005
Location: Long Island, NY
Posts: 95
Thanks for your feedback, will let you know the results when I'm able to clean the valves.

[B] [COLOR="Red"][U][B]Current Alfa's[/B][/U][/COLOR]
[B]1995 164LS[/B]
[B]1990 Spider Quad[/B]
[B]1986 GTV6[/B]
1971 GTV 1750[/B]
jpc823 is offline  
post #7 of 11 (permalink) Old 12-07-2007, 09:26 AM
Registered User
 
Join Date: Sep 2005
Posts: 2
I have the same on mine..... Where is the ventilation placed?

1986 GTV6 3.0 12V
2002 156 GTA SW
macahan is offline  
post #8 of 11 (permalink) Old 12-07-2007, 11:14 AM
Registered User
 
Balocco211's Avatar
 
Join Date: May 2006
Location: AROO Territory
Posts: 577
Group 4

This .pdf of Group 4 should help. On my 1982 I don't have the canister (#4).

Check valve is (#9) located under rear deck lid cover behind and above rear seats.

Problems usually occur when oily residue accumulates in areas 3, 4, and 6; occasionally blocked check valve.

Greg Gordon has an outstanding a tech bulletin on this:
L-Jetronic

Here are 1987 Tech notes from the late great Fred Di Matteo (Velocissima-AONE)

And for the 1983 and before models; EMM.pdf attached, section D-21 from Group 4, probably best shows the check valve in question #3 (notice no charcoal canaster; in 1983 and before from oil separator to firewall then hardline (#2 - on vehicle interior) to rear of alfetta where check valve placed in line prior to vent line and expansion tank)
Attached Images
File Type: pdf Group4_pg4-18_ESLDP.pdf (344.6 KB, 168 views)
File Type: pdf Tank Pressure problems.pdf (450.9 KB, 144 views)
File Type: pdf EMM_Pg33_D21_FS_leakage.pdf (310.3 KB, 125 views)

Last edited by Balocco211; 12-07-2007 at 08:20 PM.
Balocco211 is offline  
post #9 of 11 (permalink) Old 12-07-2007, 05:17 PM
Registered User
 
Join Date: Sep 2005
Posts: 2
Thanks Balocco211

1986 GTV6 3.0 12V
2002 156 GTA SW
macahan is offline  
post #10 of 11 (permalink) Old 03-08-2008, 07:19 PM Thread Starter
Registered User
 
jpc823's Avatar
 
Join Date: Dec 2005
Location: Long Island, NY
Posts: 95
Clogged vent valves was my problem. After cleaning no further problem

[B] [COLOR="Red"][U][B]Current Alfa's[/B][/U][/COLOR]
[B]1995 164LS[/B]
[B]1990 Spider Quad[/B]
[B]1986 GTV6[/B]
1971 GTV 1750[/B]
jpc823 is offline  
post #11 of 11 (permalink) Old 03-10-2008, 03:08 PM
Registered User
 
fast goat's Avatar
 
Join Date: Jun 2006
Location: Stratford, Ontario, Canada
Posts: 49
Missing Vent Valve

My car does not have a vent valve (removed by PO?).
Does anyone know of a suitable replacement?
Thanks for your help..
fast goat is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome